Results 1 to 12 of 12

Thread: [RESOLVED] Deploy Asp.Net webforms app.

  1. #1

    Thread Starter
    eXtreme Programmer .paul.'s Avatar
    Join Date
    May 2007
    Location
    Chelmsford UK
    Posts
    23,329

    Resolved [RESOLVED] Deploy Asp.Net webforms app.

    I've just finished recreating a GUI in webforms (VS2008). I've managed to get it working with the codebehind class, a global module, and a few of the slightly modified core classes from my desktop app.
    I've built the project and it works ok in debug mode, but i can't successfully deploy it. These are the classes i used...

    Name:  31-07-2020_02.12.28.png
Views: 31
Size:  19.3 KB

    I've tried deploying with the built .dll and the .aspx files, which doesn't work. My web hosting provide a web.config file behind the scenes.
    I have another 3.5 framework webforms app. that runs fine on my hosting, but that is a much simpler app, consisting of just the .aspx, the codebehind, and the compiled .dll...

    What files do i need to deploy?

  2. #2
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    105,187

    Re: Deploy Asp.Net webforms app.

    I haven't used Web Forms for a long time so I don't know all the ins and outs but can't you just right-click on the project and select Publish?

  3. #3
    Frenzied Member
    Join Date
    Nov 2017
    Posts
    1,101

    Re: Deploy Asp.Net webforms app.

    Do you have access to IIS on your hosting machine? This may be outdated advice, but I know that back in previous versions of Windows Server (2003, 2008, etc.) if you "deploy" an ASP.NET project that contains dependencies to the server by simply copying all appropriate files to the server, the folder that the files get placed in to needed to be configured as an Application within IIS in order for all dependent .dll files to be loaded, etc.

    I haven't touched anything relating to that kind of stuff on whatever the most recent Windows Server version is, so not sure if that process still is required.

  4. #4
    Learning .Net danasegarane's Avatar
    Join Date
    Aug 2004
    Location
    VBForums
    Posts
    5,846

    Re: Deploy Asp.Net webforms app.

    This is what I do when I publish my sample site to Someone.

    1. Right Click Project and Publish to a folder in Release Mode.
    2. Zip the content of the Publish folder.
    3. Upload the zip file to Deploy location.
    4. Unzip the files
    5. Access the Web.

    Where do you deploy the files(Hosting Provider)
    Please mark you thread resolved using the Thread Tools as shown

  5. #5

    Thread Starter
    eXtreme Programmer .paul.'s Avatar
    Join Date
    May 2007
    Location
    Chelmsford UK
    Posts
    23,329

    Re: Deploy Asp.Net webforms app.

    As I said, I have a simpler 3.5 framework web forms app. that Iíve had running on the same site for a few years. I remember from the time I deployed that app. that I needed to talk to my web hosting support people who helped me set it up. This time theyíve said they donít see any problems. Iíll try the publish command...

  6. #6
    Learning .Net danasegarane's Avatar
    Join Date
    Aug 2004
    Location
    VBForums
    Posts
    5,846

    Re: Deploy Asp.Net webforms app.

    Sure. If you are facing the issue again, Share the error message.
    Last edited by danasegarane; Jul 30th, 2020 at 09:22 PM. Reason: changed content
    Please mark you thread resolved using the Thread Tools as shown

  7. #7

    Thread Starter
    eXtreme Programmer .paul.'s Avatar
    Join Date
    May 2007
    Location
    Chelmsford UK
    Posts
    23,329

    Re: Deploy Asp.Net webforms app.

    Ok. Here's the error page...

    Attachment 178143

    Here's the full size page...

    http://www.scproject.biz/error_form.png

  8. #8

    Thread Starter
    eXtreme Programmer .paul.'s Avatar
    Join Date
    May 2007
    Location
    Chelmsford UK
    Posts
    23,329

    Re: Deploy Asp.Net webforms app.

    That's the error if i upload web.config. Without the web.config file...

    Attachment 178144

    Here's the full size page...

    http://www.scproject.biz/error_form2.png

  9. #9
    Learning .Net danasegarane's Avatar
    Join Date
    Aug 2004
    Location
    VBForums
    Posts
    5,846

    Re: Deploy Asp.Net webforms app.

    This is not giving full details of the error. Please modify the config file and find this tag

    Code:
    <configuration>
        <system.web>
        <customErrors mode="Off>
        </system.web>
    </configuration>
    This will display full details of the error message.
    Please mark you thread resolved using the Thread Tools as shown

  10. #10

    Thread Starter
    eXtreme Programmer .paul.'s Avatar
    Join Date
    May 2007
    Location
    Chelmsford UK
    Posts
    23,329

    Re: Deploy Asp.Net webforms app.

    @danasegarane

    Here's the full error now...

    http://www.scproject.biz/error_form.png

  11. #11
    Learning .Net danasegarane's Avatar
    Join Date
    Aug 2004
    Location
    VBForums
    Posts
    5,846

    Re: Deploy Asp.Net webforms app.

    From the Error, I can see that the IIS folder is not setup correctly. The Server is not able to recognize the Asp.net Application. Also I see that the Version of .Net framework is configured as 4.0.

    Either change the version of IIS in root directory of the application or in the Application Pool

    Also do I clean and Rebuild , then deploy the project.

    This is clearly a version mismatch error
    Last edited by danasegarane; Jul 31st, 2020 at 01:27 AM. Reason: Updated details
    Please mark you thread resolved using the Thread Tools as shown

  12. #12

    Thread Starter
    eXtreme Programmer .paul.'s Avatar
    Join Date
    May 2007
    Location
    Chelmsford UK
    Posts
    23,329

    Re: Deploy Asp.Net webforms app.

    Quote Originally Posted by danasegarane View Post
    From the Error, I can see that the IIS folder is not setup correctly. The Server is not able to recognize the Asp.net Application. Also I see that the Version of .Net framework is configured as 4.0.

    Either change the version of IIS in root directory of the application or in the Application Pool

    Also do I clean and Rebuild , then deploy the project.

    This is clearly a version mismatch error
    Ok thanks for the explanation. I'll call my web hosting tech support later and sort this problem out...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width