Results 1 to 29 of 29

Thread: Image embeds got replaced with a URL on VBF that doesn't exist

  1. #1

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Image embeds got replaced with a URL on VBF that doesn't exist

    I use imgur to host images related to my code, and opened a thread today to find the images were not showing up. First thinking it was a problem with imgur, I started an edit on the post to get the URLs to check, and found they've all been replaced by http://www.vbforums.com/images/ieimages/2017/09/1.jpg; all images were replaced with this same url which doesn't even exist (in another thread it's a url with 2018 instead of 2017 that replaced all the images, doesn't exist either, and some have 05 or 10 instead of 09, but they're definitely not all unique). Most of my older posts don't seem to be effected (yet), but my shell browse and shell tree were, but only the first two posts in the thread? Posts farther down still show the images. Everything was ok yesterday.

    What the heck guys?

    Am I going to have to track down all the images and edit the urls, or can this be automatically undone, and will it just happen again?
    I'm working on putting the right images back, but this is what it looked like, assuming this image doesn't get replaced too:
    Last edited by fafalone; Jun 24th, 2020 at 07:50 PM.

  2. #2

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Ok wth I fixed the URLs and by the time I finished fixing post #2 all the images in post #1 and the other thread had been changed back. But the picture in the above post is fine??? Why are my 2 major projects, just the first 2 posts, being specifically targeted by this? They're all plain jpgs on imgur, both the above, the old uneffected threads, and the 2 threads being targeted. Not immediately like there's some kind of filter, something is coming along and editing my posts like 7-8 minutes later, like clockwork. The 'Last edited by' stamp never changes, and I tried turning off 'automatically parse links'.

    Edit: I don't know, it's possible the system got fixated on those images and added them to some list, because I cropped off a couple pixels, re-uploaded, and they seem to be staying... for now... this is crazy.
    Last edited by fafalone; Jun 24th, 2020 at 09:12 PM.

  3. #3
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Glad you figured it out..

  4. #4

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Would still like to know what happened though, to prevent it from happening again and needing to keep checking all my threads. Like if there's something about the images that triggered something else to replace it, etc. Who knows what other threads it could have happened it...

    Edit: So I started checking even older threads of mine, and this has occurred in others. So yeah, really need to know what's up because I'm going to have to go through everything now
    Last edited by fafalone; Jun 25th, 2020 at 07:26 PM.

  5. #5
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    On June 9th, the site was moved to a different server. I'd guess that would have something to do with it.

    You can also STOP using the insert image function... Instead, use the Add Attachment... Images are then located in a folder on the same server as the site.

  6. #6

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    It just started deleting the image embeds again, so this is ongoing. Was there a few days ago, saw today post was silently edited with the same URL change. Didn't replace them all this time, just half. For now, in the first thread of the dozens I'll need to recheck

    I really doubt it's just me being effected, it would be really uncool to just permanently break external images. It shouldn't be that hard to track down, it's inserting a fixed string. I guess if you really want the bandwidth bump, fine, WONTFIX it and tell everyone no more off-site images :P
    Last edited by fafalone; Jul 12th, 2020 at 02:45 AM.

  7. #7

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Uh oh... can you lift the 5 attachment limit for images if they're going to need to be attached? A few of my more complex projects really need the extra images to show major features

  8. #8
    Super Moderator si_the_geek's Avatar
    Join Date
    Jul 2002
    Location
    Bristol, UK
    Posts
    41,928

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    You could create a thread in the Test forum to attach the images to, and then use the image tags in the proper thread.

    It isn't ideal, but should be manageable - especially if your Test forum post(s) include a link to the thread that the images 'belong' to.

  9. #9

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    So that's not working. It doesn't embed the images, it just creates a hyperlink to the attachment.
    Attachment 178052

    Can we please do something about the image limit or just search the source code for 'images/ieimages' and find out why this is happening? It just trashed all 12 images in my 2nd biggest project, they were fine a couple days ago. Edit: And trashed several of them several more times while I was trying to edit and replace them. I put a lot of work into these projects guys this sucks
    Last edited by fafalone; Jul 24th, 2020 at 08:04 PM.

  10. #10
    Super Moderator si_the_geek's Avatar
    Join Date
    Jul 2002
    Location
    Bristol, UK
    Posts
    41,928

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    a test (using the attachment in the post above):


    using: [IMG] https://www.vbforums.com/attachment....hmentid=178052 [/IMG]

  11. #11

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    The above method in Post #10 seems to be working so far, much appreciated

  12. #12

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    This bug is no longer confining itself to the first 1-2 posts in a thread, a bunch of my posts deep into a thread got wiped.

    It seems to have successfully grabbed one image, but then it's been applying that to a bunch of other images...


    [img]http://www.vbforums.com/images/ieimages/2017/10/1.jpg[/img]

    Like in https://www.vbforums.com/showthread....=1#post5453875

    I've made a ton of screen shots over the years and now it's really *all* of them getting slowly eaten up by this bug... it's one thing just the lead posts... but is there really nothing to be done about this broken feature?

  13. #13
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    fafalone - I and other moderators have read through this thread a few times... The short version is that it's very complex..

    The good news, is that I've been posting on forums of all types for over 20 years and have never seen or heard an issue like you've described.

    The other good news is that YOU are the only person that has.

    I think you know that if it's a bug with vbulletin then we're stuck with the problem.

    There is a 50/50 chance we'll be switching to another software.... Don't hold your breath until you see it.

    BUT, and there is always a but - If you can type up fool proof - bullet proof instructions that I can follow to RECREATE the issue I'll gladly forward it on to the development team.

    NOTE that I have no control over what they do with the information.... If asked to give the issue a priority, I'd rate it as LOW.

  14. #14

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Well I know it can be recreated by inserting imgur embeds with the img tag on the posts that have been targeted. E.g. the 1st and 2nd posts in the ShellBrowse thread. If you edit to put in an imgur embed, within 10 minutes or so the embed is replaced. I just did it now... edited at 5:43 pm to put an image at the bottom, by 5:51 it had been replaced-- This time it was successful in taking the image and moving it to vbforums, but it looks like only 1 per post works. I tried adding 2 more after and it replaced them with the 2017/10/1.jpg above.

    So you'd take this post, put in a couple imgur sources, [img]http://www.vbforums.com/images/ieimages/2017/10/1.jpg[/img][img]http://www.vbforums.com/images/ieimages/2017/10/1.jpg[/img], save, then check back in 10min or so, and they'll either be missing, duplicates of a different image, or possibly successfully transferred. And actually, you can see it processing too-- if you click 'Edit' again and look at the source, the post source it loads up contains the new URLs even before the displayed page replaces them.


    I had assumed you admins had full access to the site, no? I'd figure somewhere in the PHP the 'ieimages' string has to appear, and that should reveal exactly what's happening.

    In principle it's a good feature, I see what it's trying to do-- take externally hosted images and host them locally instead, which would prevent losing them if the host shut down or deleted them. But it's screwing up far more often than it's working.

    Agree it's low priority for a dev team, it's just super annoying since I've posted a ton of images in a ton of threads over the years, and they're just randomly getting by this. How it could just effect me... it doesn't effect 100% of posts, just random ones like 5 or 6 of my threads it's hit so far, out of a few dozen? And old ones... the newer ones were ok. Probably not many other people that have such a long history of external image use.
    Last edited by fafalone; Apr 7th, 2021 at 05:23 PM.

  15. #15
    Super Moderator Shaggy Hiker's Avatar
    Join Date
    Aug 2002
    Location
    Idaho
    Posts
    39,164

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Fafalone has the first reported case of forum Alzheimer's: Over time, memory just fades away.

    There IS a thread that has pretty extensive use of links to external images. I'm thinking mostly of Niya and the Post Race. However, those links might be different. I've never seen his mermaids get replaced. Removed, of course, but not replaced. It's really odd that nobody else appears to be seeing this. That suggests that these images are different in some way, and the only way that seems possible is the source URL of the image, but that doesn't seem all that unusual.
    My usual boring signature: Nothing

  16. #16
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    If the images are being loaded to another site FIRST - I'd try a different site to rule out who's messing with the file locations.

  17. #17

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    This bug is now spreading deeper into threads. The 2nd post of my cTaskDialog thread was recently trashed.

    The last two posts are not related; there's nothing wrong with the remote URL.

    The remote URL going 404 wouldn't cause the URL "http://www.vbforums.com/images/ieimages/2014/09/1.jpg" to be substituted. And it's not 404, if I put it back, the image appears, for a few minutes, before the forum trashes it again.

    I made a very nice thread with a lot of images to show how to use a fairly popular project of mine. I'm not excited about spending an hour for the elaborate workaround of attaching the images to another thread then referencing them from there. How long before my image hosting thread is trashed now?
    Last edited by fafalone; Jan 26th, 2024 at 01:02 PM.

  18. #18
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Quote Originally Posted by fafalone View Post
    This bug is now spreading deeper into threads. The 2nd post of my cTaskDialog thread was recently trashed.
    And the URL to that would be __________________________? (fill in the blank)

    What happens when you upload an image off your hard drive to our Server via the Go Advanced - Manage Attachment function?

  19. #19

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    And the URL to that would be https://www.vbforums.com/showthread....=1#post4761949? (fill in the blank)

    With images uploaded off hard drive it's 50/50 whether they show up or just a broken attachment link, and there's a limit of 5.

  20. #20
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Page 1 - Post #2 which looks pretty.... As in currently isn't "trashed." Correct??

    Last edited by fafalone; Jan 19th, 2024 at 11:03 AM. Reason: Fixed bottom download link

    Was this edit line created when you fixed the images? And not before which might have caused the thrash?

    My gut reaction is to Close the TEN year old thread and continue onto another one. I'll ask Si to chime in, but as you can image, there isn't exactly a button we need to push to stop this from happening.

    AND, I'd like to see it in it's thrashed state the next time it happens.

  21. #21

    Thread Starter
    PowerPoster
    Join Date
    Jul 2010
    Location
    NYC
    Posts
    5,932

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    I'm not sure if it did it before or after my edit. Normally it does it on it's own, but I didn't check the URLs before saving it since a) I didn't do it, and b) it has only impacted top level posts until now.

    The second post, I haven't fixed it yet-- do you see how every image is the exact same? They're supposed to all be different images. I don't have permission to upload to http://www.vbforums.com/images/ieimages and make folders on your server, so it's gotta be the forum software.

    Forgive me but while there might not be a button (though it seems unlikely there isn't, somewhere deep in the admin control panel-- it seems very unusual that they'd put in something that writes potentially gigabytes of image data to your server with no mention of it or setting anywhere), there's gotta be at least a config file switch, that could be tracked down with a source search for "ieimages" to find the associated variables.

    PS- When you click the add image button there's this on the From URL tab:

    Name:  vbfsetting.jpg
Views: 110
Size:  26.6 KB

    That setting seems broken somehow. Getting applied randomly.


    Also, the thread may have been started 10 years ago, but it's an active project, and the post was updated because of a new version release just last week. That's how this came up. New threads aren't immune for this in any case.
    Last edited by fafalone; Jan 29th, 2024 at 05:00 PM.

  22. #22
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Just an FYI...
    Attached Images Attached Images  

  23. #23
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    FaFalone - long shot question....

    All of the URL's are pointing to [URL=[B]http[/B]://www.vbforums.com/

    I guess the system automatically redirects them to the newer HTTPS ??

    I wonder if it'd make any difference if they were manually changed to HTTPS???

  24. #24
    Angel of Code Niya's Avatar
    Join Date
    Nov 2011
    Posts
    8,656

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Quote Originally Posted by Steve R Jones View Post
    The other good news is that YOU are the only person that has.
    He is not. I discovered this bug almost 2 years ago and I was never able to discover a way to reproduce it predictably. It just happens sometimes:-
    https://www.vbforums.com/showthread....=1#post5573811

    Something I said back then might be a clue to the problem. Perhaps it can help:-
    Quote Originally Posted by Niya View Post
    It's a bug. When you link to an image off site, after a while it seems VBForums caches it locally but it links to the wrong image in this cache. But not always. It works most of the time it seems.
    Last edited by Niya; Jan 31st, 2024 at 06:26 AM.
    Treeview with NodeAdded/NodesRemoved events | BlinkLabel control | Calculate Permutations | Object Enums | ComboBox with centered items | .Net Internals article(not mine) | Wizard Control | Understanding Multi-Threading | Simple file compression | Demon Arena

    Copy/move files using Windows Shell | I'm not wanted

    C++ programmers will dismiss you as a cretinous simpleton for your inability to keep track of pointers chained 6 levels deep and Java programmers will pillory you for buying into the evils of Microsoft. Meanwhile C# programmers will get paid just a little bit more than you for writing exactly the same code and VB6 programmers will continue to whitter on about "footprints". - FunkyDexter

    There's just no reason to use garbage like InputBox. - jmcilhinney

    The threads I start are Niya and Olaf free zones. No arguing about the benefits of VB6 over .NET here please. Happiness must reign. - yereverluvinuncleber

  25. #25
    PowerPoster yereverluvinuncleber's Avatar
    Join Date
    Feb 2014
    Location
    Norfolk UK (inbred)
    Posts
    2,280

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    I have recently come across examples of imgur disposing of old images older than 15 years, the particular site was from 2007. It was an unexpected event as imgur seemed to retain images longer than anyone else.

    I do not discount that it could have been a forum fault due to faulty underlying software (old forum) but it is expected - all image hosting sites seem to do it eventually. Use the waybackmachine to determine a time range of when the problem occurred, or to see the old images in situ.
    https://github.com/yereverluvinunclebert

    Skillset: VMS,DOS,Windows Sysadmin from 1985, fault-tolerance, VaxCluster, Alpha,Sparc. DCL,QB,VBDOS- VB6,.NET, PHP,NODE.JS, Graphic Design, Project Manager, CMS, Quad Electronics. classic cars & m'bikes. Artist in water & oils. Historian.

    By the power invested in me, all the threads I start are battle free zones - no arguing about the benefits of VB6 over .NET here please. Happiness must reign.

  26. #26
    Angel of Code Niya's Avatar
    Join Date
    Nov 2011
    Posts
    8,656

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    I am 100% sure it has nothing to do with imgur. When I did those tests nearly 2 years ago it was happening with images I recently uploaded. It has something to do with how VBForums itself caches linked off-site images. It changes the URL after a while, presumable to link to a local copy of the image on VBForum's own servers and the bug happens when it changes to the wrong URL.
    Treeview with NodeAdded/NodesRemoved events | BlinkLabel control | Calculate Permutations | Object Enums | ComboBox with centered items | .Net Internals article(not mine) | Wizard Control | Understanding Multi-Threading | Simple file compression | Demon Arena

    Copy/move files using Windows Shell | I'm not wanted

    C++ programmers will dismiss you as a cretinous simpleton for your inability to keep track of pointers chained 6 levels deep and Java programmers will pillory you for buying into the evils of Microsoft. Meanwhile C# programmers will get paid just a little bit more than you for writing exactly the same code and VB6 programmers will continue to whitter on about "footprints". - FunkyDexter

    There's just no reason to use garbage like InputBox. - jmcilhinney

    The threads I start are Niya and Olaf free zones. No arguing about the benefits of VB6 over .NET here please. Happiness must reign. - yereverluvinuncleber

  27. #27
    PowerPoster yereverluvinuncleber's Avatar
    Join Date
    Feb 2014
    Location
    Norfolk UK (inbred)
    Posts
    2,280

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    This forum has changed previously loaded and correct images for me as well, turning them into malformed URLs. Not recently though.

    Oh yes, Helloooo Niya.
    https://github.com/yereverluvinunclebert

    Skillset: VMS,DOS,Windows Sysadmin from 1985, fault-tolerance, VaxCluster, Alpha,Sparc. DCL,QB,VBDOS- VB6,.NET, PHP,NODE.JS, Graphic Design, Project Manager, CMS, Quad Electronics. classic cars & m'bikes. Artist in water & oils. Historian.

    By the power invested in me, all the threads I start are battle free zones - no arguing about the benefits of VB6 over .NET here please. Happiness must reign.

  28. #28
    Angel of Code Niya's Avatar
    Join Date
    Nov 2011
    Posts
    8,656

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Quote Originally Posted by yereverluvinuncleber View Post
    Oh yes, Helloooo Niya.
    Hi friend. Long time no see.

    Quote Originally Posted by yereverluvinuncleber View Post
    This forum has changed previously loaded and correct images for me as well, turning them into malformed URLs. Not recently though.
    It's quite unpredictable and doesn't seem to be a very regular thing.
    Treeview with NodeAdded/NodesRemoved events | BlinkLabel control | Calculate Permutations | Object Enums | ComboBox with centered items | .Net Internals article(not mine) | Wizard Control | Understanding Multi-Threading | Simple file compression | Demon Arena

    Copy/move files using Windows Shell | I'm not wanted

    C++ programmers will dismiss you as a cretinous simpleton for your inability to keep track of pointers chained 6 levels deep and Java programmers will pillory you for buying into the evils of Microsoft. Meanwhile C# programmers will get paid just a little bit more than you for writing exactly the same code and VB6 programmers will continue to whitter on about "footprints". - FunkyDexter

    There's just no reason to use garbage like InputBox. - jmcilhinney

    The threads I start are Niya and Olaf free zones. No arguing about the benefits of VB6 over .NET here please. Happiness must reign. - yereverluvinuncleber

  29. #29
    Administrator Steve R Jones's Avatar
    Join Date
    Apr 2012
    Location
    Largo, FL.
    Posts
    1,886

    Re: Image embeds got replaced with a URL on VBF that doesn't exist

    Too bad we can't recreate the problem on demand...

    Maybe if some of us (fafalone) could spend a little time searching here: https://www.vbulletin.org/forum/index.php

    We might be able to do something....

    Latest version: 4.2.5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width