Results 1 to 3 of 3

Thread: Android Emulator display white screen only

  1. #1

    Thread Starter
    Lively Member FunkySloth's Avatar
    Join Date
    Aug 2016
    Posts
    89

    Android Emulator display white screen only

    Hi Guys,

    I have this project that runs and deploy nicely in UWP and iOS, however, when I tried to run and deploy in Android it only display a white screen. No error been displayed.

    Name:  Whitescreen.PNG
Views: 809
Size:  25.2 KB

    Can anyone guide me about this.

    Thank you

  2. #2
    Lively Member
    Join Date
    Jan 2020
    Posts
    121

    Re: Android Emulator display white screen only

    Hello,@FunkySloth

    Follow these steps,To android emulator display white screen only

    Step 1:- You have to go to the sidebar menu.
    Step 2:- Click More>Settings.
    Step 3:- OpenGL ES Renderer and set it to Angle(D3D11) or Angle(D3D9) or Swiftshader.
    Step 4:- After that you simply restart the emulator and the issue should be gone.

    I hope above information will be useful for you.

    Thank you.

  3. #3
    Superbly Moderated NeedSomeAnswers's Avatar
    Join Date
    Jun 2002
    Location
    Manchester uk
    Posts
    2,652

    Re: Android Emulator display white screen only

    Personally i dont like the Emulators much, they are slow and dont fully replicate a phone.

    I tend to debug straight to Phone via USB, you need to enable debugging via USB somewhere in the options

    When you plug you Phone in via USB and your in your Xamarin project in VS, you will need to click the Allow message that appears on your phone, then VS will recognise you phone and it will change the Debug button to for instance - Debug Samsung G10
    Please Mark your Thread "Resolved", if the query is solved & Rate those who have helped you



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width