Page 3 of 3 FirstFirst 123
Results 81 to 89 of 89

Thread: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

  1. #81
    New Member
    Join Date
    Dec 2020
    Posts
    2

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    Krool, thanks for the great work!

    I tried to place the "[VB6] ActiveX CommonControls" in the MS VFP's IDE:

    LabelW's OK!
    CommandButtonW's OK!
    CheckBoxW's OK!
    RichTextBox's OK!
    TreeView's OK!

    But unfortunately "TextBoxW" CRASHED while I just placed it into the Form in DesignMode! I've download the "UniText"(https://www.vbforums.com/showthread....ase-2008-06-19) before, it's OK. I think maybe there's something wrong with TextBoxW during UserControl_Initialize() while TextBoxDesignMode's True.

  2. #82

    Thread Starter
    Frenzied Member
    Join Date
    Jun 2012
    Posts
    1,849

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    Quote Originally Posted by myfav View Post
    Krool, thanks for the great work!

    I tried to place the "[VB6] ActiveX CommonControls" in the MS VFP's IDE:

    LabelW's OK!
    CommandButtonW's OK!
    CheckBoxW's OK!
    RichTextBox's OK!
    TreeView's OK!

    But unfortunately "TextBoxW" CRASHED while I just placed it into the Form in DesignMode! I've download the "UniText"(https://www.vbforums.com/showthread....ase-2008-06-19) before, it's OK. I think maybe there's something wrong with TextBoxW during UserControl_Initialize() while TextBoxDesignMode's True.
    Hmm. I don't know. Why does the more complex RichTextBox work but not the TextBox?
    IMO UserControl_Initialize is not the cause as TextBoxDesignMode's not True there yet.
    Can you compile the OCX again for testing and put off Call CreateTextBox in sub _InitProperties and _ ReadProperties?
    So we pinpoint if it has something todo with the UserControl or the API window.

  3. #83
    Addicted Member
    Join Date
    Feb 2015
    Location
    Colorado USA
    Posts
    189

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    Version 3 of the Documentation and Compile Utility for Krool's controls has been released here.

    MountainMan

  4. #84
    New Member
    Join Date
    Sep 2019
    Posts
    15

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    First of all, thank you very much for your efforts, Krool. Your controls work very reliably and I use them quite often these days.

    I do have an issue with ImageLists and property pages, though. Here's how to reproduce:

    1. Create a new project and add a reference to VBCCR17
    2. Add two image list controls to a form
    3. Open the property page and add an image
    4. Now, without closing the property page select the second image list and add an image
    5. Upon selecting an image the IDE produces a run-time error 0

    Afterwards, if you try to open the property page there are some follow-up errors like "Runtime-error -2147221164 (80040154) [Class not registered]" and "Automation error" without any additional information. A restart of the IDE is required to get things working again.

    If you were to save the project after having properly added an image or two to the ImageList controls and try to re-use the property page, all the saved images are lost.

    This procedure just works with the original ImageList.

  5. #85

    Thread Starter
    Frenzied Member
    Join Date
    Jun 2012
    Posts
    1,849

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    Quote Originally Posted by Caine View Post
    First of all, thank you very much for your efforts, Krool. Your controls work very reliably and I use them quite often these days.

    I do have an issue with ImageLists and property pages, though. Here's how to reproduce:

    1. Create a new project and add a reference to VBCCR17
    2. Add two image list controls to a form
    3. Open the property page and add an image
    4. Now, without closing the property page select the second image list and add an image
    5. Upon selecting an image the IDE produces a run-time error 0

    Afterwards, if you try to open the property page there are some follow-up errors like "Runtime-error -2147221164 (80040154) [Class not registered]" and "Automation error" without any additional information. A restart of the IDE is required to get things working again.

    If you were to save the project after having properly added an image or two to the ImageList controls and try to re-use the property page, all the saved images are lost.

    This procedure just works with the original ImageList.
    Solved/Fixed. Thanks

  6. #86
    New Member
    Join Date
    Jun 2021
    Location
    Germany
    Posts
    1

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    Thank you Krool for this fantastic tool and excellent piece of work!

    I am missing the "UpTo" method of the RichTextBox component.

    If there are no plans to add it, then I will create in my code a function to do just that (InStr and SetStart).

  7. #87

    Thread Starter
    Frenzied Member
    Join Date
    Jun 2012
    Posts
    1,849

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    Quote Originally Posted by clintc View Post
    Thank you Krool for this fantastic tool and excellent piece of work!

    I am missing the "UpTo" method of the RichTextBox component.

    If there are no plans to add it, then I will create in my code a function to do just that (InStr and SetStart).
    You can post the code here when you are sure it mimics 1:1 to what the MS RTB is doing. I could add this method to VBCCR17 without breaking compatibility...

  8. #88
    New Member
    Join Date
    Aug 2019
    Posts
    2

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    ....
    Last edited by wardjk; Sep 6th, 2021 at 04:59 PM. Reason: delete

  9. #89
    New Member
    Join Date
    Aug 2019
    Posts
    2

    Re: [VB6] ActiveX CommonControls (Replacement of the MS common controls)

    Quote Originally Posted by wardjk View Post
    I've been using VBCCR16.OCX and added VBCCR17.OCX in preparation of upgrading VBCCR16 controls to VBCCR17. The buttons in the VB6 IDE Toolbox for VBCCR17.OCX only show as black squares. The buttons for VBCCR16.OCX still show fine. I'm using VB6 (SP6) on Windows 10. The image shows the symptom. The VBCCR17 buttons are between the standard default buttons and those of VBCCR16. The inclusion of VBCCR16 in the project components does not affect the symptom and is included in the project of this image just for comparison. What can I do to make the buttons of VBCCR17 show the proper icons?
    Attachment 182259
    I'd delete this post if I could. I think I had a corrupted OCX. The buttons show fine with the replaced OCX.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width