Results 1 to 5 of 5

Thread: Deploying VB App with Crystal Report Help

  1. #1

    Thread Starter
    New Member
    Join Date
    Dec 2015
    Posts
    3

    Deploying VB App with Crystal Report Help

    I am trying to deploy an application I made for Crystal Reports however I am coming across an issue that needs to be solved as soon as possible. I can build and install my application without trouble but when I attempt to open the installed application it doesn't do anything, or give me an error. This is my first time deploying a Crystal Report application so I'm sure I missed something. I have backward engineered my application and can verify that it is the Crystal Report in some way or another doing it.

    I am running Visual Studio 2015 and have been working through InstallSheild. Here are a few images on my steps through the Project Assistant..

    File Structure
    Name:  1.jpg
Views: 114
Size:  16.3 KB
    Name:  2.jpg
Views: 121
Size:  18.2 KB

    Redistributes Selected
    Name:  3.jpg
Views: 114
Size:  16.3 KB

    Everything runs fine on my development computer when I install the program and open it, but on deployed computers is where I am not able to open the program which leads me to believe it is a file I am missing.


    If you need any more information please let me know!

  2. #2
    Member
    Join Date
    Mar 2014
    Posts
    41

    Re: Deploying VB App with Crystal Report Help

    Hi
    Give us error message

  3. #3

    Thread Starter
    New Member
    Join Date
    Dec 2015
    Posts
    3

    Re: Deploying VB App with Crystal Report Help

    Thats just it. There is no error message when I open it up on an installed computer. It just doesn't open or do anything. I wish I had an error message because that would give me something to work with.

    It installs and opens perfectly on the computer with Visual Studio but not on a client computer

  4. #4
    Member
    Join Date
    Mar 2014
    Posts
    41

    Re: Deploying VB App with Crystal Report Help

    Hi
    First of all you have not mentionned which type of database you have used as back end in your application.
    I think you should install Crystal Report Runtime prerequisites on deployed computers and check if .Net Framework is present in it .After that if it works ok , if it's not, you should check your connection string and display us your code to see if something is perhaps wrong.

    We can't have a solution for your problem if you don't explain more details about your project.

  5. #5

    Thread Starter
    New Member
    Join Date
    Dec 2015
    Posts
    3

    Re: Deploying VB App with Crystal Report Help

    I actually solved this shortly after posting. I had originally tried to install the 32bit CR Runtime but I needed to have installed the 64bit. Thank you all anyways for your interest in helping

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width