I cannot get the reportviewer to work. To try to debug this, I did the following
  • Created a new ASP.Net (VB) application
  • Attached a database
  • Created a report based on a View in the database
  • Created a new page based on Site.Master
  • Added ReportViewer to the page
  • Attached Report1 to the Viewer
  • Nothing show up in the Report Viewer (it seems like something related to my report should be displayed)
  • Error when I run - The report definition for report 'Report1' has not been specified. Object reference not set to an instance of an object
  • Not sure what that means - I was thinking that nothing was connected to DataSet1, so I clicked on Configure Data Sources in the Smart Button for ReportViewer
  • Report Data Source is DataSet1. Nothing listed in Data Source Instance
  • Using the smart button for my ObjectDataSource,ConfigureDataSource, It shows me under Choose Your business Object, I picked the appropriate object
  • Going to Next , everything again looks fine. But I still get the same error.


I am not trying to do anything fancy - it just will not show the report. Any idea how to fix this, or is this a know issue with 2013?