Results 1 to 7 of 7

Thread: [RESOLVED] data source' is not a member of 'microsoft.reporting.winforms.report

  1. #1

    Thread Starter
    New Member
    Join Date
    Mar 2015
    Posts
    5

    Resolved [RESOLVED] data source' is not a member of 'microsoft.reporting.winforms.report

    Hi, I am new here so hello and I hope I don't make a fool of myself. I have been sitting with this problem for days now and cannot find where I am going wrong. I am using VB2012, I have started a new solution and created a report that is displayed in the report viewer. I am using the drill down feature but if I try to set my localreport.datasource I get the above error. I have done this many times before in other solutions, but these solutions were created in an earlier version of VB and converted. What is missing from my new solutions that it gives me this error. See image.
    Name:  localreport.jpg
Views: 874
Size:  28.0 KB

  2. #2

    Thread Starter
    New Member
    Join Date
    Mar 2015
    Posts
    5

    Re: data source' is not a member of 'microsoft.reporting.winforms.report

    Since there has been no replies but yet quite a few views, am I being silly or is this something nobody has seen before because I don't know how it can work in one solution but not another. Please, if anyone has any suggestions.

  3. #3
    PowerPoster
    Join Date
    Sep 2005
    Location
    Modesto, Ca.
    Posts
    4,548

    Re: data source' is not a member of 'microsoft.reporting.winforms.report

    I don't have an answer because I don't work with rdlc reports (if thats what this is) but
    I ignored this post because I wasn't going to try and read the code you posted, it's way to small for me. Post your code in code tags,
    Code:
    Post your
    code like 
    this
    Also, you should be able to find lots of info using Google.

  4. #4

    Thread Starter
    New Member
    Join Date
    Mar 2015
    Posts
    5

    Unhappy Re: data source' is not a member of 'microsoft.reporting.winforms.report

    Hi wes4dbt

    Thanks for your reply, apologies, like I said I am new to the forum. I purposely posted my code like that so I could use the mouse hover and catch the error that it gives in a print screen. My code per say, isn't the problem, I have used the exact code many times, I have something missing in my solution (I think) that causes the error. I have goggled until I am blue in the face, I always do and most of the time I do solve my own problems, this was a desperate plea. I don't know where to find the Code thread, I'm guessing I will have to start a new thread. Again, sorry for not using the posting correctly

  5. #5

    Thread Starter
    New Member
    Join Date
    Mar 2015
    Posts
    5

    Re: data source' is not a member of 'microsoft.reporting.winforms.report

    Hi,

    I solved my problem thanks, I had my code as:
    Private Sub TransRepViewer_Drillthrough(ByVal sender As Object, ByVal e As Microsoft.Reporting.WinForms.DrillthroughEventArgs) Handles TransRepViewer.Drillthrough
    Dim localreport = e.Report
    Dim paraminfo As ReportParameterInfoCollection = e.Report.GetParameters()

    I needed to add
    Dim localreport As LocalReport = e.Report

    never had to do it before but there we are if anyone ever has this problem

  6. #6
    PowerPoster
    Join Date
    Sep 2005
    Location
    Modesto, Ca.
    Posts
    4,548

    Re: [RESOLVED] data source' is not a member of 'microsoft.reporting.winforms.report

    I don't know where to find the Code thread
    Just click "#" for the code tags.

  7. #7

    Thread Starter
    New Member
    Join Date
    Mar 2015
    Posts
    5

    Re: [RESOLVED] data source' is not a member of 'microsoft.reporting.winforms.report

    Thank you, will do so in future.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width