Results 1 to 3 of 3

Thread: How do you fix a javascript void(o) problem?

  1. #1

    Thread Starter
    Junior Member
    Join Date
    Oct 2014
    Posts
    17

    How do you fix a javascript void(o) problem?

    I used to browse clothing sites,and never had problems before. Now when I go to the sites,I can no longer see if the item is available.It shows JavaScript void(o). Please help

  2. #2
    Frenzied Member tr333's Avatar
    Join Date
    Nov 2004
    Location
    /dev/st0
    Posts
    1,606

    Re: How do you fix a javascript void(o) problem?

    https://developer.mozilla.org/en-US/...Operators/void

    The use of void(0) is likely intentional to run js event handlers on the links instead of having the browser navigate to a href url when clicked.
    CSS layout comes in to the 21st century with flexbox!
    Just another Perl hacker,

  3. #3
    Junior Member
    Join Date
    Jan 2015
    Posts
    16

    Re: How do you fix a javascript void(o) problem?

    Got a void problem also
    im creating the webbrowser in visual basic 2010
    the problem is opening a new window in a tab
    this works with the following code



    Private Sub webbrowserfunction_NewWindow(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles Me.NewWindow
    Dim newbrowser As New webbrowserfunction
    Dim tab As New TabPage
    Dim myElement As HtmlElement = CType(frmbasicxmain.TabControl1.SelectedTab.Controls.Item(0), WebBrowser).Document.ActiveElement
    Dim target As String = myElement.GetAttribute("href")
    newbrowser.Tag = tab
    tab.Tag = newbrowser
    frmbasicxmain.TabControl1.TabPages.Add(tab)
    tab.Controls.Add(newbrowser)
    newbrowser.Dock = DockStyle.Fill
    frmbasicxmain.TabControl1.SelectedTab = tab
    newbrowser.Navigate(target)
    e.Cancel = True
    End Sub




    however the following problem appears

    the buttons to go to the links arn't ahref links but was written in javascript like this
    <a href="javascript:void(0)" title="Google" onClick="launchFull(http://www.google.be','_blank',',scrollbars=yes,status=yes,resizable=yes')">SmartAid HGW</A>


    so the upper code gives the target the void(0) value and cannot navigate...

    Can someone help me find a solution for this? Also searching to open HTTPS urls in the tabbed webbrowser trough VPN
    Somehow those pages wouldn't load

    thx in advanced

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width