Results 1 to 5 of 5

Thread: Why can't I

  1. #1

    Thread Starter
    Fanatic Member Gary.Lowe's Avatar
    Join Date
    May 2000
    Location
    In my sphere of influence
    Posts
    621

    Unhappy

    I am using ADO to create an encrypted database, this is the code I use

    Code:
    Dim cat As New ADOX.Catalog
    cat.Create ("Provider=Microsoft.Jet.OLEDB.4.0;" & _
            "Data Source=C:\new.mdb;" & _
            "Jet OLEDB:Encrypt Database=True;" & _
            "Jet OLEDB:Engine Type=5;")
    If I use Engine Type 4 it throws an invalid arguement error up.

    I can only create an Access 2 version or Access 2000.
    Does anybody know why I can't create an Access 97 version.

    Does anybody know the best way to create a database through code so that anyold person can't look at the contents, I'm not sure if this is the best method.


    Thanks
    Gary Lowe
    VB6 (Enterprise) SP5
    ADO 2.6
    SQL Server 7 SP3

    OK I know my spelling and grammer is crap so don't quote me on it!

    To err is human to take the P! is only natural !!

    Click on the top section of image for Marcus Miller website and bottom section of image for 'Run For Cover' sound clip


  2. #2
    Fanatic Member Ianpbaker's Avatar
    Join Date
    Mar 2000
    Location
    Hastings
    Posts
    696
    Hi gary

    I might be talking out of my arse but i think you need to use jet 3.5 for access97.

    it might work

    Ian
    Yeah, well I'm gonna build my own lunar space lander! With blackjack aaaaannd Hookers! Actually, forget the space lander, and the blackjack. Ahhhh forget the whole thing!

  3. #3

    Thread Starter
    Fanatic Member Gary.Lowe's Avatar
    Join Date
    May 2000
    Location
    In my sphere of influence
    Posts
    621
    Cheers Ian

    I'll try that and see what happens

    Gary Lowe
    VB6 (Enterprise) SP5
    ADO 2.6
    SQL Server 7 SP3

    OK I know my spelling and grammer is crap so don't quote me on it!

    To err is human to take the P! is only natural !!

    Click on the top section of image for Marcus Miller website and bottom section of image for 'Run For Cover' sound clip


  4. #4
    Addicted Member
    Join Date
    May 1999
    Posts
    161

    Question

    I'm fairly new at that stuff, but is Engine Type=5 not what you need for a 4.0 Jet provider ? If you specify Engine Type=4 would be for the 3.51 Jet...

    ...just reaching here.... actually asking as much as giving hints...

  5. #5

    Thread Starter
    Fanatic Member Gary.Lowe's Avatar
    Join Date
    May 2000
    Location
    In my sphere of influence
    Posts
    621

    Angry

    Cheers

    I have tried using 3.5 but that doesn't work either.

    I have used the type 4 to compact into an access 97 database through ADO using 4.0 and that works fine.

    It is not a massive problem but it's just nice to have that function
    Gary Lowe
    VB6 (Enterprise) SP5
    ADO 2.6
    SQL Server 7 SP3

    OK I know my spelling and grammer is crap so don't quote me on it!

    To err is human to take the P! is only natural !!

    Click on the top section of image for Marcus Miller website and bottom section of image for 'Run For Cover' sound clip


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width