Results 1 to 4 of 4

Thread: Window pop-up is working, but....

  1. #1

    Thread Starter
    Junior Member
    Join Date
    Feb 1999
    Location
    Turner ME USA
    Posts
    18

    Post

    I got my window pop-up thing to work well, but when it pops up, the BackColor is suppposed to be Red, but shows up transparent while the WAV is playing.

    What the heck is up with that? Any suggestions?

    Thanks!

    Jeff

  2. #2
    Hyperactive Member
    Join Date
    Sep 1999
    Posts
    305

    Post

    could you put in a line before the play wave that says Form1.BackColor = vbRed ? or maybe put in a While/wend function so that when the wave is running it continuously resets the background color?

  3. #3
    Guest

    Post

    Can answer that one...it happens to me with splash screens...I make a splash screen show while the program is loading but it doesn't finish showing the splash screen properly (it is transparent) until it has finished loading the rest of the program (defeating the whole idea of having a splash screen). Nuff chatting...

    The way I get around it is to have the form display itself properly and use a timer to load the rest of the program/play the sound file...set the timer's interval to about a quater of a second (enough time for your red form to redraw itself) and when the timer goes off have it disable the timer and play your sound file...)

    Make any sense?

    ------------------
    Matthew Ralston
    E-Mail: m.ralston@mediavault.co.uk
    ICQ:31422892
    Web Sites:The Blue Link My Home Page


  4. #4
    Hyperactive Member
    Join Date
    Oct 1999
    Posts
    309

    Post

    Couldn't you just use something like frmsplash.show to make the window paint itself completely before doing any other stuff..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width