Results 1 to 3 of 3

Thread: ReSizing Issues

  1. #1

    Thread Starter
    PowerPoster
    Join Date
    Jul 2001
    Location
    Tucson, AZ
    Posts
    2,166

    ReSizing Issues

    PROBLEM:

    Resizing works great when creating a new form but not with a previously saved form which is loaded using the previous saved values.

    I'm using Karl Moores excellent code for doing resizing. Very little overhead (ie no OCX or large class) and works great when a new form is created from scratch and controls are positoned during form load.

    THAT SAID, for some reason the ScaleWidth and ScaleHeight properties in the form_load event seem to be critical.
    If not set to full scale, the previously saved form does not seems to scale correctly.

    Since ScaleWidth and ScaleHeight are just the base for generating the percentages (DX/DY), this should not matter.
    BTW: I hardcoded ScaleWidth and ScaleHeight for the previously loaded form and all was OK.

    Anyone experienced a similiar issue using Karls code?

  2. #2
    PowerPoster
    Join Date
    Jul 1999
    Posts
    5,923
    Perhaps I'm missing something but why are you hardcoding scaleheight/width?

    Just access them from Me.ScaleWidth and Me.ScaleHeight each time you need them.

  3. #3

    Thread Starter
    PowerPoster
    Join Date
    Jul 2001
    Location
    Tucson, AZ
    Posts
    2,166
    ----------
    why are you hardcoding scaleheight/width?
    ----------

    This was just for testing. Since resize worked great for a new form but not a previously created one wanted to see what would happen if I set the scaleheight/width for a previously created one to the values used by a newly loaded one.

    Doing this, caused the previously created one to resize correctly.
    This is why I'm confused? Can't understand why this would make a difference.

    FYI: When I load a new form I size it to the MDIClient area.

    Only thing I have on the MDI Child is a PBox and HScroll bar at the bottom of the form.

    For some reason the HScroll bar disappears when sizing even though its values are stored in TAG.

    Any IDEAS?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width