Results 1 to 2 of 2

Thread: AVI- PLEASE READ!!!!!! URGENT!!!!

  1. #1

    Thread Starter
    Junior Member
    Join Date
    Nov 1999
    Posts
    24

    Post

    I have noticed that when I use the Windows API, I cannot play some avi files(nothing happens). the following is the code I use, and it only works for some avi files. Why????

    In general, declarations area:
    Private Declare Function mciSendString Lib "winmm.dll" Alias _
    "mciSendStringA" (ByVal lpstrCommand As String, ByVal _
    lpstrReturnString As Any, ByVal uReturnLength As Long, ByVal _
    hwndCallback As Long) As Long
    Public FileName
    --------------------------------------
    Open App.Path & "\" & App.EXEName & ".stp" for Input As #1
    Input #1, FileName
    close #1

    Last$ = ScreenSaver.hWnd & " Style " & &H40000000
    ToDo$ = "open " & FileName & " Type avivideo alias video parent " & Last$
    i = mciSendString(ToDo$, 0&, 0, 0)
    i = mciSendString("play video repeat", 0&, 0, 0)

  2. #2
    Guest

    Post

    I know that there are quite a few compression codec that can be used on avi files, perhaps they can't be used with the code above...

    ------------------
    Matthew Ralston
    E-Mail: m.ralston@mediavault.co.uk
    ICQ:31422892
    Web Sites:The Blue Link My Home Page

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width