Results 1 to 3 of 3

Thread: Icon help..

  1. #1

    Thread Starter
    Member
    Join Date
    Aug 1999
    Location
    West Hartford, CT, USA
    Posts
    42

    Post

    I'm trying to load an Icon that's stored in a .RES file... For some reason, when I use this method, the Icon loses its color and becomes shades of grey. If I take the same Icon and load it by using the form properties window, it appears fine.

    I've tried saving it as both a 256 color and a 16 color Icon with the same results. I'd love to just load it from the form properties, but I need to load it during program execution (it will change from time to time).

    Any help would be greatly appreciated!!

  2. #2
    Guru Aaron Young's Avatar
    Join Date
    Jun 1999
    Location
    Red Wing, MN, USA
    Posts
    2,176

    Post

    What are you using to load the Resource?
    This works fine for me on NT & Win95:

    Icon = LoadResPicture(101, vbResIcon)

    ------------------
    Aaron Young
    Analyst Programmer
    aarony@redwingsoftware.com
    adyoung@win.bright.net

  3. #3

    Thread Starter
    Member
    Join Date
    Aug 1999
    Location
    West Hartford, CT, USA
    Posts
    42

    Post

    Yes.. That's how I'm doing it.

    I just don't get it -- When I view the Icon with the VB Resource Editor, it looks fine. It's only when it's displayed on the screen that I get a "grey" icon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width