dcsimg
Results 1 to 7 of 7

Thread: Service Application Installation

  1. #1

    Thread Starter
    Hyperactive Member
    Join Date
    Mar 2013
    Posts
    362

    Service Application Installation

    Hello:

    I am trying to run this code to install a service app. It is a batch file.

    Code:
    net use u: \\w2012\users
    u:
    cd Steve A\VS_Projects\SendEmail_TimeManagement2\SendEmail_TimeManagement2\bin\Debug
    "c:\Windows\Microsoft.NET\Framework\v2.0.50727\InstallUtil.exe" SendEmail_TimeManagement2
    pause
    When I run the file as an administrator, it tells me it cannot find the file specified, which does exist!

    Name:  2020-03-24 18_02_19-Settings.jpg
Views: 53
Size:  14.5 KB

    Thanks for the help!

  2. #2
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    104,120

    Re: Service Application Installation

    That's not VB.NET code and this site has a forum dedicated to Application Installation, so this thread obviously does not belong in this forum. I have asked the mods to move it.

  3. #3

    Thread Starter
    Hyperactive Member
    Join Date
    Mar 2013
    Posts
    362

    Re: Service Application Installation

    jmc: where should it have been gone? The batch file is flawless. Its more about installing the service application written in Visual Studio. My apologies for not putting it in the correct place.

  4. #4
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    104,120

    Re: Service Application Installation

    Quote Originally Posted by ssabc View Post
    where should it have been gone?
    There might be a clue in my previous post.
    Quote Originally Posted by ssabc View Post
    Its more about installing the service application
    Exactly.

  5. #5

    Thread Starter
    Hyperactive Member
    Join Date
    Mar 2013
    Posts
    362

    Re: Service Application Installation

    I see a section under Application Deployment, not Application Installation. I can wait for your moderators to move this, as I don't want to create any redundancy. But what is more puzzling is why it cannot see the file that's right there in the directory I'm initiating the command from. I haven't written a service app since VS2008, but I do not remember even having to do it this way.

  6. #6
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    104,120

    Re: Service Application Installation

    Quote Originally Posted by ssabc View Post
    I see a section under Application Deployment, not Application Installation.
    Sorry, my mistake. I must have been influenced by the "Application Installation" in your thread title. That said, installation is part of deployment so the connection is fairly clear. Anyway, it appears that the thread has been moved.

    You might try copying and pasting the contents of that console window because that screenshot is pretty much unreadable.

  7. #7

    Thread Starter
    Hyperactive Member
    Join Date
    Mar 2013
    Posts
    362

    Re: Service Application Installation

    The error reads:
    Exception occurred while initiating the application:
    System.IO.FileNotFoundException: Could not load file or assembly 'file:///U:\Steve A\VS_Projects\SendEMail_TimeManagement2\SendEMail_TimeManagement2\bin\Debug\SendEMail_TimeManagement 2' or one of its dependencies. The system cannot find the file specified..

    This file, SendEMail_TimeManagement2.exe exists plain as day in the folder, and the build ran without error.

    If I specify the extension 'exe' on the file, which I did not see done in some examples I previewed, added to the error is ;The module was expected to contain an assembly manifest..'
    Last edited by ssabc; Mar 25th, 2020 at 12:20 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width