dcsimg
Results 1 to 6 of 6

Thread: After install, app requires higher version of .net Framework

  1. #1

    Thread Starter
    Member
    Join Date
    Aug 2014
    Posts
    47

    After install, app requires higher version of .net Framework

    I'm encountering a very strange problem.

    Using Visual Basic 2010 Express, I have written a very simple screenshot program. The target framework of the project is .net 3.5. I am targeting 3.5 because I need to use the screenshot program on an old computer that I rarely use.

    I have created an installer using Advanced Installer.

    The installation itself works fine. However, when I start the screenshot program in my old computer, the following warning appears:

    To run this application, you first must install one of the following versions of the .NET Framework: v4.0.30319

    As mentioned above, the target framework was 3.5. I've checked everything in the project, including opening designer files and there is no indication that the target framework is anything other than 3.5. In the project references, the references are all 2.0.0.0 or 3.5.0.0

    Does anyone have a suggestion as to what the problem might be and how to resolve this?
    Last edited by walt4; Aug 24th, 2019 at 04:35 PM.

  2. #2
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    102,753

    Re: After install, app requires higher version of .net Framework

    This question really has nothing to do with VB.NET. This site has an Application Deployment forum and that's where questions on application deployment should be posted. I've asked the mods to move this thread.

  3. #3
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    102,753

    Re: After install, app requires higher version of .net Framework

    Have you tried putting the application on another machine manually, without the installer? If that works then that would suggest that the issue is the installer and not the application.

  4. #4
    New Member
    Join Date
    Jul 2019
    Posts
    8

    Re: After install, app requires higher version of .net Framework

    I have only used VS 2019 and had this same problem there, so I hope you could try something along the lines for VB 2010 as well. Try the following:

    1) Go to the properties for your setup package and find 'Prerequisities'. Make sure that your version of .NET framework is selected and not other versions.
    2) Now, go to 'Launch conditions' (try right-click on your setup package and select 'view'). Locate '.NET Framework' in this window and go to its properties. Now, change the 'version' property to your required version.

    Let me know if this works.

  5. #5

    Thread Starter
    Member
    Join Date
    Aug 2014
    Posts
    47

    Re: After install, app requires higher version of .net Framework

    Thanks jmcilhinney and Swop_K.

    As it turns out, the error was due to my own carelessness. When creating the installer, I inadvertently referred to the original version of my screenshot program which was using .NET 4.0, and not my updated version which uses .NET 3.5. The change in the file name was only 1 character, so I didn't see my mistake.

    If the moderators would like to move this thread, perhaps the Posts From Careless Coders forum would be the best match.

  6. #6

    Thread Starter
    Member
    Join Date
    Aug 2014
    Posts
    47

    Re: After install, app requires higher version of .net Framework

    Thanks jmcilhinney and Swop_K.

    As it turns out, the error was due to my own carelessness. When creating the installer, I inadvertently referred to the original version of my screenshot program which was using .NET 4.0, and not my updated version which uses .NET 3.5. The change in the file name was only 1 character, so I didn't see my mistake.

    If the moderators would like to move this thread, perhaps the Posts From Careless Coders forum would be the best match.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width