dcsimg
Results 1 to 4 of 4

Thread: Problem with Kernel-mode-driver, please help

  1. #1

    Thread Starter
    Junior Member
    Join Date
    Dec 2018
    Posts
    18

    Problem with Kernel-mode-driver, please help

    Hi everybody,

    I run the project "VB6Driver" (Thanks to The trick: http://www.vbforums.com/showthread.p...el-mode-driver) on Windows 7 32 bit, the system seemed to hang a bit (But only in the first run), then give the message: "Could not start service". I think the problem is in Driver, because with the same "TestDriver" project, I successfully booted another Kernel Driver written in C ++.

    Can someone please help me handle this problem?

  2. #2
    Frenzied Member
    Join Date
    Feb 2015
    Posts
    1,364

    Re: Problem with Kernel-mode-driver, please help

    Hello.
    Did you run the patch utility to remove the runtime after compilation:
    Compile the project with all the default optimization. To exclude the runtime of the import, I use a utility Patch, I used here. I'm a little modify it, as initially could not start the driver and long puzzled because of what it does, and the reason was the checksum. After exclusion of the import library checksum has changed, and I do not update it. And EXE, DLL, etc. this field is not checked, and the driver checks. To check the watch imports in any viewer PE:
    Will it work then? Please, show the driver's import when you apply the patch.

  3. #3

    Thread Starter
    Junior Member
    Join Date
    Dec 2018
    Posts
    18

    Re: Problem with Kernel-mode-driver, please help

    Quote Originally Posted by The trick View Post
    Hello.
    Did you run the patch utility to remove the runtime after compilation:

    Will it work then? Please, show the driver's import when you apply the patch.
    Thank you, Driver worked well.
    Thanks again for your sharing

  4. #4

    Thread Starter
    Junior Member
    Join Date
    Dec 2018
    Posts
    18

    Re: Problem with Kernel-mode-driver, please help

    Quote Originally Posted by The trick View Post
    Hello.
    Did you run the patch utility to remove the runtime after compilation:

    Will it work then? Please, show the driver's import when you apply the patch.
    Thank you, Driver worked well.
    Thanks again for your sharing

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width