dcsimg
Results 1 to 4 of 4

Thread: unable to find Arduino path in visual basic studio

  1. #1

    Thread Starter
    New Member
    Join Date
    Dec 2018
    Location
    Copenhagen, Danmark
    Posts
    3

    unable to find Arduino path in visual basic studio

    Hi,

    I am working on Azure IoT project using MXchip AZ3166 board. I installed visual basic studio and Arduino. I installed Azure IoT workbench Dev kit in visual basic. I configured Aurdino path in it. When I compiled a sample projects from Azure IoT workbench I am encountering a error stating that install Arduino or add Arduino path and another error unable to find Aurdino path.

    Kindly anyone suggest me some solutions to solve this error. Thank you.

    Sri Krishna

  2. #2
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    102,018

    Re: unable to find Arduino path in visual basic studio

    This site has a dedicated IoT forum. I have asked the mods to move this thread. Please don't double-post in the mean time.
    Last edited by jmcilhinney; Dec 26th, 2018 at 07:13 PM.

  3. #3
    Super Moderator Shaggy Hiker's Avatar
    Join Date
    Aug 2002
    Location
    Idaho
    Posts
    33,631

    Re: unable to find Arduino path in visual basic studio

    It's certainly a valid question, so it deserves better than Chit-Chat. Posts in Chit-Chat don't count...and replies can be quite strange.
    My usual boring signature: Nothing

  4. #4

    Thread Starter
    New Member
    Join Date
    Dec 2018
    Location
    Copenhagen, Danmark
    Posts
    3

    Re: unable to find Arduino path in visual basic studio

    Solution by Jiong Shi:

    Problem Encountered: Unable to find Arduino path in Visual Studio.
    Encountering a error stating that install Arduino or add Arduino path and another error unable to find Aurdino path.


    Open "File > Preference > Settings and add following lines to set the configurations for Arduino".

    * Windows

    ```JSON
    "arduino.path": "C:\\Program Files (x86)\\Arduino",
    "arduino.additionalUrls": "https://raw.githubusercontent.com/VSChina/azureiotdevkit_tools/master/package_azureboard_index.json"
    ```

    * macOS

    ```JSON
    "arduino.path": "/Application",
    "arduino.additionalUrls": "https://raw.githubusercontent.com/VSChina/azureiotdevkit_tools/master/package_azureboard_index.json"
    ```

    * Ubuntu

    ```JSON
    "arduino.path": "/home/{username}/Downloads/arduino-1.8.8",
    "arduino.additionalUrls": "https://raw.githubusercontent.com/VSChina/azureiotdevkit_tools/master/package_azureboard_index.json"
    ```
    For more information, please refer to the docs above.

    And on more thing, according to the official release notes, the following notes should be known.

    1. Arduino IDE 1.8.7 has some breaking changes, causing board package and library installation failures. It is recommended to that you install version 1.8.6 or 1.8.8
    2. The supported Arduino IDE versions are 1.6.x and later are supported.
    3. The Windows Store's version of the Arduino IDE is not supported because of the sandbox environment that the application runs in.

    Also
    Open "File > Preference > Settings in Arduino IDE

    In Additional boards manager copy paste:
    "https://raw.githubusercontent.com/VSChina/azureiotdevkit_tools/master/package_azureboard_index.json"

    And restart Arduino.


    Sri Krishna

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width