PHP User Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: bbcode_highlight in ..../includes/functions.php on line 4197
[RESOLVED] Database name missing when loading crystal report-VBForums
Results 1 to 3 of 3

Thread: [RESOLVED] Database name missing when loading crystal report

  1. #1

    Thread Starter
    Junior Member
    Join Date
    Aug 2018
    Location
    France, North
    Posts
    23

    Resolved [RESOLVED] Database name missing when loading crystal report

    Hi, I have a big issue and I don't find a solution even if the problem seems common.

    On my computer, my crystal report load perfectly fine, but when I try to run my application on another computer, a pop-up SQL connection appears like this one :

    Name:  Error CR.PNG
Views: 376
Size:  8.9 KB

    As you can see, the database name is missing, I don't understand why , I let you my code below :

    VB.NET Code:
    1. With crConnectionInfo
    2.             .ServerName = "servername"
    3.             .DatabaseName = "databasename"
    4.             .UserID = "id"
    5.             .Password = "password"
    6.         End With
    7.  
    8.         CrTables = cryRpt.Database.Tables
    9.         For Each CrTable In CrTables
    10.             crtableLogoninfo = CrTable.LogOnInfo
    11.             crtableLogoninfo.ConnectionInfo = crConnectionInfo
    12.             CrTable.ApplyLogOnInfo(crtableLogoninfo)
    13.         Next

    I want to deploy on a windows 7 computer with SQL 2008, if you already have the problem or if you have any idea I would be very grateful.

    Have a nice day !

  2. #2

    Thread Starter
    Junior Member
    Join Date
    Aug 2018
    Location
    France, North
    Posts
    23

    Re: Database name missing when loading crystal report

    After I have tried some tests, I changed the property "Integrated security" on TRUE, and then surprise !
    My Database name is there !

    Name:  Error CR2.PNG
Views: 144
Size:  18.8 KB

    But, because there is always a but, when I click to connect, I have another error, it say : "Connexion failled. Try Again."

    Name:  Error CR3.PNG
Views: 144
Size:  14.9 KB

    As you can imagine, I tried to try again without success

    If anyone can help me to resolve it, I will be very grateful, have a good day, hope read you soon !

  3. #3

    Thread Starter
    Junior Member
    Join Date
    Aug 2018
    Location
    France, North
    Posts
    23

    Re: Database name missing when loading crystal report

    Hi, I finally found by myself,

    I had the problem on windows 7 first, and that was because I do not have the file access on the Client PC to open the crystal report.

    And I had it to windows 10, more difficult one, finally, it was the SQL Native Client which was missing on the right version for windows 10.

    Hope it will help some people in the same case.

    Have a good day !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width