dcsimg
Results 1 to 3 of 3

Thread: [RESOLVED] DropDownList won't open?

  1. #1

    Thread Starter
    PowerPoster
    Join Date
    Jan 2004
    Location
    Southern California
    Posts
    4,832

    Resolved [RESOLVED] DropDownList won't open?

    I have an ASPX Form that contains a GridView. One of the columns has a DropDownList control in it. While testing, the Gridview contains 6 rows. Each of the DDL's is populated via a database read. I check each one to make sure they are populated correctly. However, when I get to the last DDL and try to check it...it won't expand or open. I placed some debug statements in the routine that populates the DDL and based on the output, the last DDL was also populated. When I execute the page and it renders, I inspect the DDL and I can't expand it in there either but I can expand the other DDL's. I've never seen this before and it has me perplexed. Any ideas?

    Here is some images of the HTML Inspect.

    Thanks,Name:  BadDDL.jpg
Views: 299
Size:  11.7 KBName:  GoodDDL.jpg
Views: 294
Size:  13.3 KB
    Last edited by blakemckenna; Aug 31st, 2018 at 10:25 AM.
    Blake

  2. #2
    Hyperactive Member
    Join Date
    Nov 2017
    Posts
    398

    Re: DropDownList won't open?

    I'm going to hassle you about posting images, since you've been a member for almost 15 years and are closing in on 5000 posts. Don't post images of text. It wasn't even clear to me what you were trying to show in the two images until I saw in the browser title bar that one of the images was named "Good..." and the other was "Bad..."

    So, in the "Bad..." image, there are no <Option Value> lines listed, the DDL is empty, so that is why you can't click the DDL.

    So, then the question is, why does your code properly populate the other DDL's and not this one? For that, you would need to post your ASP.NET code that is populating them.

  3. #3

    Thread Starter
    PowerPoster
    Join Date
    Jan 2004
    Location
    Southern California
    Posts
    4,832

    Re: DropDownList won't open?

    Sorry about the images. I ended getting it fixed. The problem was there was another routine that executed after the routine that populated the DDL's. This other routine actually instantiated the DDL, which, on the last one, it just cancelled out the population of the DDL.
    Blake

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width