dcsimg
Results 1 to 5 of 5
  1. #1

    Thread Starter
    PowerPoster
    Join Date
    Jan 2004
    Location
    Southern California
    Posts
    4,750

    Resolved [RESOLVED] Thumbnail image won't process?

    I have a personal web app that I am building that basically allows friends/family to view vacation photos. I had things working as they should until I added some new logic, which was asp:Button elements. Before I was using <div> elements to create Buttons but was unable to link those buttons to code-behind...so I switched over to using asp:Button controls.

    The idea is when a user clicks on a button, it will show thumbnail images which will allow the user to click on any of them and take the user to a new page with a larger image. That was working fine prior to the button switch. Now, when a user clicks on a thumbnail, nothing happens. I'm not sure why it's doing this. I have attached the two Web Forms and their code-behind for anyone interested in taking a looking at the issue.

    If you need more files, let me know!

    I'm grateful for your help!

    Thanks,
    Blake

  2. #2

    Thread Starter
    PowerPoster
    Join Date
    Jan 2004
    Location
    Southern California
    Posts
    4,750

    Re: Thumbnail image won't process?

    Anyone have any idea on this?
    Blake

  3. #3
    .NUT jmcilhinney's Avatar
    Join Date
    May 2005
    Location
    Sydney, Australia
    Posts
    98,907

    Re: Thumbnail image won't process?

    Quote Originally Posted by blakemckenna View Post
    Before I was using <div> elements to create Buttons but was unable to link those buttons to code-behind...so I switched over to using asp:Button controls.
    Could you not have just used Hyperlink controls, which would have generated <a> tags in the HTML and ended up much as you already had?

    Regardless, perhaps showing us the code that works and the code that doesn't would enable us to spot the difference and this the issue.
    Why is my data not saved to my database? | MSDN Data Walkthroughs
    VBForums Database Development FAQ
    My CodeBank Submissions: VB | C#
    My Blog: Data Among Multiple Forms (3 parts)
    Beginner Tutorials: VB | C# | SQL

  4. #4

    Thread Starter
    PowerPoster
    Join Date
    Jan 2004
    Location
    Southern California
    Posts
    4,750

    Re: Thumbnail image won't process?

    jmc,

    I've attached the WebForm files in a zip file. There's not much code so I'm sure this would be a cake walk for you. Getting back to your idea of using a HyperLink, are you referring to the ASP.Net control "HyperLink"? If this is the case, the way I see doing this is dynamically. Please correct me if I'm wrong.

    Thanks,
    Attached Files Attached Files
    Blake

  5. #5

    Thread Starter
    PowerPoster
    Join Date
    Jan 2004
    Location
    Southern California
    Posts
    4,750

    Re: Thumbnail image won't process?

    I figured this out. I needed to add a Global variable and add a call to the UploadImage to the Page_Load event.
    Blake

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width


×
We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.