dcsimg
Page 2 of 2 FirstFirst 12
Results 41 to 44 of 44

Thread: [RESOLVED] Error 481 - Invalid picture in compiled exe (vb6 sp6) in Win7 II

  1. #41

    Thread Starter
    Lively Member
    Join Date
    May 2011
    Posts
    99

    Re: Error 481 - Invalid picture in compiled exe (vb6 sp6) in Win7 II

    And yet another test:
    Omitted STDOLE2.tlb from manifest and dependencies
    Bonnie West's code adds an image of the icon to the center of the form:
    256x256 - 24, 48x48 - 24, 32x32 - 24, 16x16 - 24
    48x48 - 8, 32x32 - 8, 16x16 - 8
    32x32 - 4, 16x16 - 4
    On my Development Host windows 7 (x64) PC, zThreeD.exe works:
    Icon does appear on zThreeD.exe main form title bar and center of form.
    Icon does appear on zThreeD.exe desktop shortcut (after screen Refresh).
    Icon does appear in zThreeD.exe shortcut properties.
    Icon does appear on zThreeD.exe.
    Icon does appear in zThreeD.exe properties.

    On my test windows 10 (x64) PC, zThreeD.exe works:
    Icon does appear on zThreeD.exe main form title bar and center of form.
    Old Icon does appear on zThreeD.exe desktop shortcut (Unaffected by Refresh or reboot?).
    - - - (This behavior with the Desktop Shortcut icon seems to resolve itself or can be 'fixed' by uninstall > reboot > install)
    Icon does appear in zThreeD.exe shortcut properties.
    Icon does appear on zThreeD.exe.
    Icon does appear in zThreeD.exe properties.

    On my wife's windows 7 (x64) PC, zThreeD.exe installs but does not work: Error 481 - Invalid picture
    * Icon does NOT appear on zThreeD.exe main form title bar: Error 481 - Invalid picture
    Icon does appear on zThreeD.exe desktop shortcut.
    Icon does appear in zThreeD.exe shortcut properties.
    Icon does appear on zThreeD.exe.
    Icon does appear in zThreeD.exe properties.
    Last edited by anderci; Sep 15th, 2017 at 06:37 AM.

  2. #42

    Thread Starter
    Lively Member
    Join Date
    May 2011
    Posts
    99

    Re: Error 481 - Invalid picture in compiled exe (vb6 sp6) in Win7 II

    The test results, above, are the same with all of my tiny test apps (zNoOCX, zRichTx, zThreeD and zMSComct)

    The zNoOCX installation package no longer contains stdole2.tlb any other dependency files.

    I simply copied (from my PC via the USB memory stick) the zNoOCX.exe file to my wife's windows 7 (x64) PC into a D:\Program Files (x86)\Clark_Anderson\zNoOCX folder and ran it:

    IT WORKS!

    Doggonit, that was a fluke: every thing works in my wife's logon??

    Even Administrator logon does not make everything work?? This work/not work in other logons includes the 'copied' zNoOCX.exe file. I may have to take this puzzle back to the NSIS forum or...?

    Thank you, Spooman for the instructions...
    Last edited by anderci; Sep 15th, 2017 at 09:27 AM.

  3. #43
    Fanatic Member Spooman's Avatar
    Join Date
    Mar 2017
    Posts
    869

    Re: Error 481 - Invalid picture in compiled exe (vb6 sp6) in Win7 II

    Anderci

    Congrats.
    Lord knows this has been quite the exercise ..

    May I make the following suggestion .. mark the thread as RESOLVED.
    To do so
    1. Look just above your 1st post
    2. Click the Thread Tools button
    3. Click the Mark as Resolved option


    Spoo

  4. #44

    Thread Starter
    Lively Member
    Join Date
    May 2011
    Posts
    99

    Re: Error 481 - Invalid picture in compiled exe (vb6 sp6) in Win7 II

    My guess, at this point, is the 'Error 481 - Invalid picture' was an unusual symptom response to security issues??

    I certainly would like a better understanding of this. Does my NSIS installation script need adjusting for it?
    Last edited by anderci; Sep 15th, 2017 at 05:23 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width