dcsimg
Results 1 to 10 of 10

Thread: VB 2010 WebBrowser - page wont load completely

  1. #1

    Thread Starter
    Junior Member
    Join Date
    Jan 2014
    Posts
    19

    Question VB 2010 WebBrowser - page wont load completely

    Hello all;

    I'm using a Webbrowser control to login to Google Webmaster Tools. For some reason the main page wont load completely. Some parts of the page get loaded but not all as you would see in the image below.

    <<< sorry having trouble inserting the image>>>

    Any idea why this happens? Any solutions? Your suggestions are greatly appreciated.

    (I use IE Version 11)

    Thank you

    JB

  2. #2
    Super Moderator dday9's Avatar
    Join Date
    Mar 2011
    Location
    South Louisiana
    Posts
    9,540

    Re: VB 2010 WebBrowser - page wont load completely

    So all you are doing is navigating your WebBrowser control to the Google webmaster tool page, nothing else, and it will not load all of the components? Seems like something is breaking down. Try re-inserting the image. Here is a step by step guide on how to do it:

    Step 1. Click on the 'Insert Image' button in either the quick reply or the advanced reply
    Name:  insert image.png
Views: 367
Size:  8.0 KB

    Step 2. Click on the 'Basic Uploader' button in the 'Insert Image' dialog in the 'From Computer' tab. You may have to manually select 'From Computer' if 'From URL' is selected by default
    Name:  basic uploader.png
Views: 374
Size:  6.4 KB

    Step 3. Click on the 'Browse' button, navigate to your screen shot, and click on 'Upload Image'
    Name:  upload image.png
Views: 364
Size:  6.3 KB

    This should give you something that looks like this:
    [ATTACH]012345[/ATTACH]
    Do not delete that, that is what displays the image whenever you post the reply.

  3. #3

    Thread Starter
    Junior Member
    Join Date
    Jan 2014
    Posts
    19

    Question Re: VB 2010 WebBrowser - page wont load completely

    Thank you 'dday9' for the instructions.

    So all you are doing is navigating your WebBrowser control to the Google webmaster tool page, nothing else, and it will not load all of the components?
    Yes, and this is what the page look like... as you can see it's trying to load, but not.

    Name:  WMT.JPG
Views: 350
Size:  33.2 KB

    I left the page for an hour to load but it still looked like this at the end... I don't know what's wrong.

    Can some one please help? Thanks!

    JB

  4. #4
    Frenzied Member
    Join Date
    Oct 2012
    Location
    Tampa, FL
    Posts
    1,187

    Re: VB 2010 WebBrowser - page wont load completely

    You may have to try a different web browser control. There are a couple Gecko based ones.

  5. #5

    Thread Starter
    Junior Member
    Join Date
    Jan 2014
    Posts
    19

    Re: VB 2010 WebBrowser - page wont load completely

    Quote Originally Posted by jayinthe813 View Post
    You may have to try a different web browser control. There are a couple Gecko based ones.
    bummer! is this mean I have rewrite/redesign everything?

  6. #6
    Frenzied Member
    Join Date
    Oct 2012
    Location
    Tampa, FL
    Posts
    1,187

    Re: VB 2010 WebBrowser - page wont load completely

    Quote Originally Posted by jayb View Post
    bummer! is this mean I have rewrite/redesign everything?
    Most likely involves a rewrite to access the web page contents since the control will change. It looks like the webpage involves some kind of AJAX or dynamic loading which can be hard to work with, if it works at all in the Web Browser Control. Are you using the latest version of IE? You can try installing or upgrading your version as the control uses the version installed on the local system. You might have better luck with the more recent versions.

    You can take a look at something like the following:
    https://code.google.com/p/geckofx/
    '
    do some searches for "Web Browser Control .NET"

  7. #7
    PowerPoster
    Join Date
    Oct 2010
    Posts
    2,141

    Re: VB 2010 WebBrowser - page wont load completely

    What is your Windows and VS version? I just created a browser app in VS2008 and I had no problem getting to that site under both Vista/32 and Win8.1/64.

    Maybe you have a firewall or other security software running that is blocking access.

    Edit:

    When you launch Internet explorer, go to the Help->about menu. What version does that so installed on your computer?
    Last edited by TnTinMN; Feb 26th, 2014 at 08:16 PM.

  8. #8
    Super Moderator dday9's Avatar
    Join Date
    Mar 2011
    Location
    South Louisiana
    Posts
    9,540

    Re: VB 2010 WebBrowser - page wont load completely

    Quote Originally Posted by TnTinMN View Post
    Edit:

    When you launch Internet explorer, go to the Help->about menu. What version does that so installed on your computer?
    In his first post, he stated IE 11.

  9. #9

    Thread Starter
    Junior Member
    Join Date
    Jan 2014
    Posts
    19

    Re: VB 2010 WebBrowser - page wont load completely

    Are you using the latest version of IE? You can try installing or upgrading your version as the control uses the version installed on the local system. You might have better luck with the more recent versions.
    Yes I have the latest IE version 11. I have the same issue with another site (SBI Sitebuilder). When I go to these sites using the IE they all works fine. So it must be something to do with webbrowser control.

    You can take a look at something like the following:
    https://code.google.com/p/geckofx/
    I will take a look. Thanks!

  10. #10

    Thread Starter
    Junior Member
    Join Date
    Jan 2014
    Posts
    19

    Re: VB 2010 WebBrowser - page wont load completely

    Quote Originally Posted by TnTinMN View Post
    What is your Windows and VS version? I just created a browser app in VS2008 and I had no problem getting to that site under both Vista/32 and Win8.1/64.

    Maybe you have a firewall or other security software running that is blocking access.
    I have Windows 7. I designed the app in VB Express 2010. I don't have a problem visiting these site with IE.

    Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width