dcsimg
Results 1 to 4 of 4
  1. #1

    Thread Starter
    Lively Member
    Join Date
    Aug 2000
    Location
    Singapore
    Posts
    108

    Exclamation Cannot create DAO DB Engine

    Greetings.

    Packaged a reporting application with VB 6.0 and Crystal Report 7, using both Access 97 and 2000 database.

    When I tried installing onto another Win98 machine, without CR, VB and Ms Office, it gives me the above error when I trigger the reporting function.

    I tried installing MDAC 2.5 but it still doesnt work.

    Please help. Thank you.

    KT

  2. #2
    Frenzied Member Buzby's Avatar
    Join Date
    Jan 1999
    Location
    UK
    Posts
    1,670
    It's probably Crystal Reports. I bet if you installed CR on the PC in question it would work fine.

    Crystal Reports is a complete pain in the neck when it comes to dependancy files - it's sooo complicated they've even shipped it with a special help file telling you which files you need to include. Take a look in there first, go through each section, picking out the files you need (there are required files for data access, files for features you've put in your reports (like charts, maps etc), files for export formats, all sorts).
    Then you can either edit the CRPE32.DEP file on your system to include all these files (this gets picked up by the P&D Wizard when you packaged the app), or you can manually add the required files to the P&D Wizard before it creates the .CAB file.
    'Buzby'
    Visual Basic Developer
    "I'm moving to Theory. Everything works there."

  3. #3

    Thread Starter
    Lively Member
    Join Date
    Aug 2000
    Location
    Singapore
    Posts
    108
    Thanz Buzby.

    That's the answer which I found in another forum whereby this guy install CR and everything works fine.

    But this is quite unacceptable to get all my users to install CR, just to get this application running.

    Tried searching seagate for a remedy, and they claimed that the version of P2bdao.dll, P2ctdao.dll and P2irdao.dll makes a difference. However, that article only applies to CR 4.6, which is irrelevant to my CR 7.0.

    Just like to find out if anyone out there facing the same problem, with similar specs.

    Rgds.

    KT

  4. #4

    Thread Starter
    Lively Member
    Join Date
    Aug 2000
    Location
    Singapore
    Posts
    108
    Strange.....seems like installing Ms Office solve everything.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width


×
We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.