trouble with mscomct2.ocx-VBForums
Results 1 to 6 of 6

Thread: trouble with mscomct2.ocx

  1. #1

    Thread Starter
    New Member
    Join Date
    Jun 2013
    Posts
    1

    trouble with mscomct2.ocx

    In order to register mscomct2.ocx (which is in syswow64) I go to cmd.exe as Administrator, then enter : regsvr32.exe c:\windows\syswow64\mscomct2.ocx.

    It works and I get the message that it has been registered.

    THEN I go to VB 6.0, and under the Project tab I click on "Components". I find "Microsoft Windows Common Controls-2 6.0(SP6)" which is mscomct2.ocx.

    I check it but whether I then click on "OK" or on "Apply" I get ther message FILE NOT FOUND !!

    How can I register it or find it under c:\windows\syswow64 (in Explorer) and yet VB 6.0/Project/Components tells me "File not Found" ? Now what ?

  2. #2
    Junior Member
    Join Date
    Apr 2013
    Posts
    21

    Re: trouble with mscomct2.ocx

    Have you tried unregistering that OCX first before you register it? How about using the Browse button of the Components dialog box in order to add that OCX?

  3. #3
    Fanatic Member gibra's Avatar
    Join Date
    Oct 2009
    Location
    ITALY
    Posts
    663

    Re: trouble with mscomct2.ocx

    This problem is caused by Internet Explorer 10

    Uninstall it to solve.


  4. #4
    Junior Member
    Join Date
    Apr 2013
    Posts
    21

    Re: trouble with mscomct2.ocx

    Quote Originally Posted by gibra View Post
    Uninstall it to solve.
    So, there's no other way?

  5. #5
    Fanatic Member gibra's Avatar
    Join Date
    Oct 2009
    Location
    ITALY
    Posts
    663

    Re: trouble with mscomct2.ocx

    Quote Originally Posted by Sachiko View Post
    So, there's no other way?
    There's not.
    IE is the problem.

    IE11 work good without problems.

  6. #6
    PowerPoster
    Join Date
    Feb 2006
    Posts
    11,332

    Re: trouble with mscomct2.ocx

    Quote Originally Posted by jpbordeaux View Post
    In order to register mscomct2.ocx (which is in syswow64) I go to cmd.exe as Administrator, then enter : regsvr32.exe c:\windows\syswow64\mscomct2.ocx.
    While the IE10 problem is well known, you may simply be doing this incorrectly.

    To begin with, installing VB6 on such a machine should have already taken care of this there. if it didn't, then you didn't install VB6 correctly and probably a ton of other things are broken.

    But if you insist on manually self-registering this (and most) ActiveX libraries you must do it from an elevated context.

    Quote Originally Posted by jpbordeaux View Post
    I go to cmd.exe as Administrator
    Bzzt! Not good enough. You are the weakest link, goodbye!

    What you need to do is start cmd.exe elevated. The easiest way to do this is to log on as a member of the Administrators group, then press the Windows key, type cmd.exe in the Search box, and then hold Ctrl-Shift and only then press the Enter key. This should result in a UAC prompt. Accept that and an elevated command prompt opens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width

Survey posted by VBForums.