[RESOLVED] The libs.CopyLibs.classpath property is not set up-VBForums
Results 1 to 2 of 2

Thread: [RESOLVED] The libs.CopyLibs.classpath property is not set up

  1. #1

    Thread Starter
    Web developer Nightwalker83's Avatar
    Join Date
    Dec 2001
    Location
    Adelaide, Australia
    Posts
    11,439

    Resolved [RESOLVED] The libs.CopyLibs.classpath property is not set up

    Hi,

    After trying to run some homework exercises I had just finished typing the code for I receive message below in the IDE! Although, my lecturer didn't mention or I have forgotten if he did whether I needed to add any libraries to the project.

    J:\5AJA\Sessions\Session9\Session9 Exercises\nbproject\build-impl.xml:460: The libs.CopyLibs.classpath property is not set up.
    This property must point to
    org-netbeans-modules-java-j2seproject-copylibstask.jar file which is part
    of NetBeans IDE installation and is usually located at
    <netbeans_installation>/java<version>/ant/extra folder.
    Either open the project in the IDE and make sure CopyLibs library
    exists or setup the property manually. For example like this:
    ant -Dlibs.CopyLibs.classpath=a/path/to/org-netbeans-modules-java-j2seproject-copylibstask.jar
    BUILD FAILED (total time: 0 seconds)

    I have added both .jar files located in the "/ant/extra folder" directory to the project by both the "Tools > Libraries" menu and by right clicking the "Libraries" folder in the "Projects" windows and clicking "Add Jar/Folder" and adding both .jar files to the project then trying to run it. However, Still receive the above message.

    Thanks,


    Nightwalker
    If this thread is finished with please mark it "Resolved" by selecting "Mark thread resolved" from the "Thread tools" drop-down menu.
    Please consider giving me some rep points if I help you a lot.
    DON'T BUMP YOUR POSTS!!! Links to my code examples can now be found on my website: My websites
    Please rate my post if you find it helpful!
    Technology is a dangerous thing in the hands of an idiot! I am that idiot.

  2. #2

    Thread Starter
    Web developer Nightwalker83's Avatar
    Join Date
    Dec 2001
    Location
    Adelaide, Australia
    Posts
    11,439

    Re: The libs.CopyLibs.classpath property is not set up

    Removing the above reference from the xml file and recompiling the project fixed the problem although, I am unsure how the reference ended up in the xml since creating a new project and adding and same files to it doesn't produce any error when I run it.

    Edit:

    Here are the steps to fix the problem.
    Last edited by Nightwalker83; Oct 24th, 2012 at 06:44 PM. Reason: Adding more!
    If this thread is finished with please mark it "Resolved" by selecting "Mark thread resolved" from the "Thread tools" drop-down menu.
    Please consider giving me some rep points if I help you a lot.
    DON'T BUMP YOUR POSTS!!! Links to my code examples can now be found on my website: My websites
    Please rate my post if you find it helpful!
    Technology is a dangerous thing in the hands of an idiot! I am that idiot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width

Survey posted by VBForums.