WinSock issues in vs2010-VBForums
Results 1 to 5 of 5

Thread: WinSock issues in vs2010

  1. #1

    Thread Starter
    New Member
    Join Date
    Apr 2012
    Posts
    3

    WinSock issues in vs2010

    we have an application developed in vs2008 that uses winsock controls (mswinsock.ocx, with appropriate dlls). we are in the process of moving our solution over to a new computer with vs2010, with a win7 64bit os.

    we have been able to register the mswinsck.ocx successfully in c:\windows\syswow64.
    our solution compiles (both in debug mode and release) just fine on the development computer and even builds a full installer (somewhat) successfully.

    our issue is that when we try to run the application on a client machine in a winxp 32bit environment it throws an error: "You must have a license to use this ActiveX control."

    I noticed that it copied the ocx and dll's for this control into our application folder on the client machine, but there was no mswinsck.ocx in c:\windows\system32 on the client machine.
    I did try to manually register the ocx on the client machine, but still no luck.

    Any ideas would be VERY much appreciated. Thanks in advance!!

  2. #2
    PowerPoster Nightwalker83's Avatar
    Join Date
    Dec 2001
    Location
    Adelaide, Australia
    Posts
    13,254

    Re: WinSock issues in vs2010

    What happens when you copy the "mswinsck.ocx" from the application folder on the client machine to "c:\windows\system32", register it then attempt to execute your application?
    when you quote a post could you please do it via the "Reply With Quote" button or if it multiple post click the "''+" button then "Reply With Quote" button.
    If this thread is finished with please mark it "Resolved" by selecting "Mark thread resolved" from the "Thread tools" drop-down menu.
    Please consider giving me some rep points if I help you a lot.
    Links to my code examples can now be found on my website: My websites
    Please rate my post if you find it helpful!
    Technology is a dangerous thing in the hands of an idiot! I am that idiot.

  3. #3

    Thread Starter
    New Member
    Join Date
    Apr 2012
    Posts
    3

    Re: WinSock issues in vs2010

    We have tried that. Same results. The error that comes back does not appear to be because it is not registered - we don't receive a Class not registered error.

    We have also tried on development machine to build with the control activated in just about every folder possible - SysWOW64, System32, bin/debug, bin/release, etc...

  4. #4
    PowerPoster Nightwalker83's Avatar
    Join Date
    Dec 2001
    Location
    Adelaide, Australia
    Posts
    13,254

    Re: WinSock issues in vs2010

    Just out of curiosity do you encounter the problem if you compile the project in VS2008 than run it on the client's machine or does the problem only happen with VS2010?
    when you quote a post could you please do it via the "Reply With Quote" button or if it multiple post click the "''+" button then "Reply With Quote" button.
    If this thread is finished with please mark it "Resolved" by selecting "Mark thread resolved" from the "Thread tools" drop-down menu.
    Please consider giving me some rep points if I help you a lot.
    Links to my code examples can now be found on my website: My websites
    Please rate my post if you find it helpful!
    Technology is a dangerous thing in the hands of an idiot! I am that idiot.

  5. #5

    Thread Starter
    New Member
    Join Date
    Apr 2012
    Posts
    3

    Re: WinSock issues in vs2010

    The license issue only happens on the client machines when we use an installer that was compiled with vs2010.

    If we compile with 2008, it works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width

Survey posted by VBForums.