Runtime error 430 class does not support automation or does not support expected.....-VBForums
Results 1 to 3 of 3

Thread: Runtime error 430 class does not support automation or does not support expected.....

  1. #1

    Thread Starter
    New Member
    Join Date
    Apr 2012
    Posts
    3

    Runtime error 430 class does not support automation or does not support expected.....

    Hi everybody,

    I am new a member, I used to go through this forum as a non-member, I have learned lot from it. First thanks all to made this happen.

    I am facing a problem in project, Pl. find details below and help to fix soon.

    Project Info: I am developing a GUI-Project in vb6.0 using third party DLL (one is .net dll which is using one more c++ dll) to interact with external hardware.

    What I have done: I registered .net dll using regasm and created tlb and the same to be reference in vb6.0

    Current Status: I able to create object for the .net class and able call most of the methods of it... those are all working well. However when I call a particular method (Transmit) its giving following runtime error.

    "Runtime error 430 Class does not support automation or does not support expected interface"

    As per our one of thread I have ensured DLLs to be the latest. Since only one or two method is not working. I unable to locate the problem. Also I tried with another PC... it went vain.

    Pl. help me out from this ASAP- since I was trying fix this from last 3-4 days.

    With best regards,
    Suresh

  2. #2

    Thread Starter
    New Member
    Join Date
    Apr 2012
    Posts
    3

    Re: Runtime error 430 class does not support automation or does not support expected.

    I forgot to mention that third party .net demo application using the same method (Transmit) - that's working...

  3. #3

    Thread Starter
    New Member
    Join Date
    Apr 2012
    Posts
    3

    Re: Runtime error 430 class does not support automation or does not support expected.

    I decoded the .net dll to source code to know why there are some methods/classes are not working in Vb6.0 even after its registered properly....... It seems like the methods - overloaded with same no. of arguments and classes - having constructor with argument(s) are only not working. Pl. clarify Am I Correct?

    Since this is third party dll, can you pl. suggest alternate way to fix this. Awaiting your valuable feedback.

    With best regards,
    Suresh T.K.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width

Survey posted by VBForums.