Problem hosting a Silverlight movie properly in aspx and html-VBForums
Results 1 to 2 of 2

Thread: Problem hosting a Silverlight movie properly in aspx and html

Hybrid View

  1. #1

    Thread Starter
    Fanatic Member vuyiswamb's Avatar
    Join Date
    Jan 2007
    Location
    South Africa
    Posts
    793

    Problem hosting a Silverlight movie properly in aspx and html

    Good Evening All

    I have Silverlight application and it is rendering better(not Good) in IE and it renders differently from different browsers, like IE8,Firefox 3, 4, and worse in Chrome. i tried different examples , i used one example that was good , but the moment i view this in different browsers its just a mess.

    here is my Page
    Code:
    <%@ Page Language="C#"      AutoEventWireup="true" %>
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" >
    <head runat="server">
        <title>EchashDev</title>
        <style type="text/css">
        html, body {
    	    height: 100%;
    	    overflow:auto;
    	    float:left;
        }
        body {
    	    padding: 0;
    	    margin: 0;
        }
        #silverlightControlHost {
    	    height: 100%;
    	    text-align:left;
        }
        </style>
        <script type="text/javascript" src="Silverlight.js"></script>
        <script type="text/javascript">
            function onSilverlightError(sender, args) {
                var appSource = "";
                if (sender != null && sender != 0) {
                  appSource = sender.getHost().Source;
                }
                
                var errorType = args.ErrorType;
                var iErrorCode = args.ErrorCode;
    
                if (errorType == "ImageError" || errorType == "MediaError") {
                  return;
                }
    
                var errMsg = "Unhandled Error in Silverlight Application " +  appSource + "\n" ;
                 
                errMsg += "Code: "+ iErrorCode + "    \n";
                errMsg += "Category: " + errorType + "       \n";
                errMsg += "Message: " + args.ErrorMessage + "     \n";
    
                if (errorType == "ParserError") {
                    errMsg += "File: " + args.xamlFile + "     \n";
                    errMsg += "Line: " + args.lineNumber + "     \n";
                    errMsg += "Position: " + args.charPosition + "     \n";
                }
                else if (errorType == "RuntimeError") {           
                    if (args.lineNumber != 0) {
                        errMsg += "Line: " + args.lineNumber + "     \n";
                        errMsg += "Position: " +  args.charPosition + "     \n";
                    }
                    errMsg += "MethodName: " + args.methodName + "     \n";
                }
    
                throw new Error(errMsg);
            }
        </script>
    </head>
    <body background="http://ecash.ebam.co.za/Silverlight/images/MainBackground.jpg">
        <form id="form1" runat="server" style="height:100%">
        <div id="silverlightControlHost" >
            <object  data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="100%" height="100%">
    		  <param name="source" value="ClientBin/EchashDev.xap"/>
              <param name="background" value="transparent" />
    		  <param name="minRuntimeVersion" value="4.0.50826.0" />
              <param name="onerror" value="OnErrorEventHandler"/>
              <param name="Windowless" value="True" />
    		  <param name="uiculture" value="<%= System.Threading.Thread.CurrentThread.CurrentUICulture %>" />
              <param name="culture" value="<%= System.Threading.Thread.CurrentThread.CurrentCulture %>" />
    		  <param name="autoUpgrade" value="true" />
    		  <a href="http://go.microsoft.com/fwlink/?LinkID=149156&v=4.0.50826.0" style="text-decoration:none">
     			  <img src="http://go.microsoft.com/fwlink/?LinkId=161376" alt="Get Microsoft Silverlight" style="border-style:none"/>
    		  </a>
    	    </object><iframe id="_sl_historyFrame" style="visibility:hidden;height:0px;width:0px;border:0px"></iframe></div>
        </form>
    </body>
    </html>
    and the Live website is http://ecash.ebam.co.za/Silverlight

    i am using Firefox 5,when i run the page, the Silverlight movie does not get rendered, but in IE9 it does not get rendered but not nicely. you will see what i mean when you browse to the give Url.

    Thanks

  2. #2
    Frenzied Member Lightning's Avatar
    Join Date
    Oct 2002
    Location
    Eygelshoven
    Posts
    1,565

    Re: Problem hosting a Silverlight movie properly in aspx and html

    I tried both Chrome and IE9. The Silverlight app works just fine in both browser, but I don't see a movie at all????
    VB6 & C# (WCF LINQ) mostly


    If you need help with a WPF/WCF question post in the NEW WPF & WCF forum and we will try help the best we can

    My site

    My blog, couding troubles and solutions

    Free online tools

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width

Survey posted by VBForums.