I've spent the last couple days looking through this and other forums and I was never able to find a way to supress the save as dialog you get if you try to do a simple print to the adobe pdf printer from VBA code.

I finally found the answer for anyone interested. Go to the list of printers in the Windows Settings list and right click the Adobe PDF icon and click on Properties. On the Advanced tab click on the Printing Defaults button. There is a setting there for Adobe pdf output folder. By default this is set to prompt the user. If you click the browse button you can set a folder for it to save to. There is also a checkbox you can use to turn off the autoloading of the document after it is created.

On the General tab there is also a button that says Printing Preferences. This will bring you to the same place I described in the last paragraph, but for some reason it seemed that I had to do the settings again. I don't know why this would be but I just did the same settings for the default folder. When I ran my code it finally worked.