Weird graphics when running WPF app on XP-VBForums
Results 1 to 11 of 11

Thread: Weird graphics when running WPF app on XP

  1. #1

    Thread Starter
    Pro Grammar chris128's Avatar
    Join Date
    Jun 2007
    Location
    England
    Posts
    7,598

    Weird graphics when running WPF app on XP

    OK so I've been developing an instant messenger style program (to help me learn WCF) and I've been using WPF to create the client side GUI. I've been testing it on my Vista machine which is a pretty decent spec but now that I have come to run it on an XP machine at work that is fairly slow, I have problems with the way the app draws itself when it loads. This is how it is supposed to look:



    and this is how it looks SOMETIMES when I load it on my XP machine (The green bits are where my desktop background is showing through it, which obviously shouldnt be happening)



    The strange thing is that like I said, this only happens sometimes. I can run the app 10 times in a row and probably 6 or 7 of those times it will look all weird like in that screenshot but the other 3 times it looks fine.

    One thing to note is that I am using an animation to show the window (the animation just increases the scale from 0 to 1), as you can see I am using a transparent window with my own border inside it that looks like a window, so that I can have my own window chrome and shape. Im assuming that the animation and the transparent window have got something to do with it but I would of thought there shouldnt be any problems with that...

    Any ideas?

    Cheers
    Chris
    My free .NET Windows API library (Version 2.2 Released 12/06/2011)

    Blog: cjwdev.wordpress.com
    Web: www.cjwdev.co.uk


  2. #2
    Hyperactive Member Arrow_Raider's Avatar
    Join Date
    Dec 2001
    Location
    AVR Lovers Club
    Posts
    423

    Re: Weird graphics when running WPF app on XP

    I have had rendering glitches happen in wpf apps that I fixed by updating my graphics card driver.
    My monkey wearing the fedora points and laughs at you.

  3. #3
    Lively Member
    Join Date
    Jul 2007
    Posts
    127

    Re: Weird graphics when running WPF app on XP

    yeah, i wonder if its a video card issue like arrow said. did u try it on any other XP machines? another thing i would be curious about it if u turned off all the visual effects in vista, and see if it renders alright. (control panel>system>advanced>Performance)

  4. #4

    Thread Starter
    Pro Grammar chris128's Avatar
    Join Date
    Jun 2007
    Location
    England
    Posts
    7,598

    Re: Weird graphics when running WPF app on XP

    I tried it on another machine and it seemed to work ok (after I did a repair on the .NET framework anyway as another part of the app wouldnt work on that one!). So I guess it must just be that PC that is messed up... I also tried installing DirectX 10 on that machine but no change. I'll see if there is an update for the graphics card driver as the machine is fairly old.

    Thanks
    My free .NET Windows API library (Version 2.2 Released 12/06/2011)

    Blog: cjwdev.wordpress.com
    Web: www.cjwdev.co.uk


  5. #5
    Hyperactive Member Arrow_Raider's Avatar
    Join Date
    Dec 2001
    Location
    AVR Lovers Club
    Posts
    423

    Re: Weird graphics when running WPF app on XP

    You can try playing with the registry values mentioned on this page:
    http://msdn.microsoft.com/en-us/library/aa970912.aspx

    You can try enabling the "Disable Hardware Acceleration Option" mentioned on that page, but that will probably make wpf apps run slower.
    My monkey wearing the fedora points and laughs at you.

  6. #6
    Frenzied Member
    Join Date
    Jul 2008
    Location
    Rep of Ireland
    Posts
    1,381

    Re: Weird graphics when running WPF app on XP

    This has to do with driver issues for XP. Chris remember the code bank submission I wrote for check the hardware capabilities of a pc for vista I have it there that Microsoft know about the issues but since they are driver issues it may not get resolved.

  7. #7

    Thread Starter
    Pro Grammar chris128's Avatar
    Join Date
    Jun 2007
    Location
    England
    Posts
    7,598

    Re: Weird graphics when running WPF app on XP

    Bummer... no one is going to be moving away from XP anytime soon so this seems to be a rather big problem for WPF..
    My free .NET Windows API library (Version 2.2 Released 12/06/2011)

    Blog: cjwdev.wordpress.com
    Web: www.cjwdev.co.uk


  8. #8
    Frenzied Member
    Join Date
    Jul 2008
    Location
    Rep of Ireland
    Posts
    1,381

    Re: Weird graphics when running WPF app on XP

    Have you downloaded the latest drivers for your GFX card?

  9. #9

    Thread Starter
    Pro Grammar chris128's Avatar
    Join Date
    Jun 2007
    Location
    England
    Posts
    7,598

    Re: Weird graphics when running WPF app on XP

    Not yet, havent been back in the office since I posted this thread
    My free .NET Windows API library (Version 2.2 Released 12/06/2011)

    Blog: cjwdev.wordpress.com
    Web: www.cjwdev.co.uk


  10. #10
    Frenzied Member
    Join Date
    Jul 2008
    Location
    Rep of Ireland
    Posts
    1,381

    Re: Weird graphics when running WPF app on XP

    Ah to be home, ok try the drivers then let me know!

  11. #11
    New Member
    Join Date
    Nov 2006
    Posts
    3

    Re: Weird graphics when running WPF app on XP

    Have had this same problem on varying old xp machines with poor graphics cards for a long time using WPF apps.

    I typed dxdiag in to Start > Run and brought up the directx properties. On display disable the acceleration options for direct draw and direct 3d.

    Seemed to work for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width

Survey posted by VBForums.