dcsimg
Results 1 to 3 of 3

Thread: [RESOLVED] Compile error in hidden module

  1. #1

    Thread Starter
    Lively Member
    Join Date
    Oct 2008
    Posts
    89

    Resolved [RESOLVED] Compile error in hidden module

    I have an extensive program that has been running with out any issues for about two months. Now, without any reason or cause that I can find, it stopped.

    On start-up, I get a "Compile error in hidden module" error. This occurs in the code for the Workbook Open code. This program was literally working one day and about six hours later...it developed this problem. I have no idea what transpired over that six hours.

    It appears that my "libraries" have been lost? The reason I say this is that it seems to get stuck on the codes involving "Environ" and "Date". The error involving the Date reads "Compile Error: Can't find project or library". Any ideas how this happened or even better...how to recover it?? As it would be, I have several consecutively created back-ups of the project. Each one returns the same problem(s). I have also tried it on several other workstations with the same results...

    ANY help on this would be GREATLY appreciated...Thanks in advance!

  2. #2
    Don't Panic! Ecniv's Avatar
    Join Date
    Nov 2000
    Location
    Amsterdam...
    Posts
    5,343

    Re: Compile error in hidden module

    Sounds like the machine had something uninstall/upgraded, which has broken your registry/references. Can you re-install office it will probably fix it.

    To find out, go toyour VB Editor, on the menu tools>References

    This should open a window with all references used. Those marked as missing are the ones you need.

    Post up if you can't reinstall. Are there any other machines nearby you can test on to see if they have the same problem?

    BOFH Now, BOFH Past, Information on duplicates

    Feeling like a fly on the inside of a closed window (Thunk!)
    If I post a lot, it is because I am bored at work! ;D Or stuck...
    * Anything I post can be only my opinion. Advice etc is up to you to persue...

  3. #3

    Thread Starter
    Lively Member
    Join Date
    Oct 2008
    Posts
    89

    Re: Compile error in hidden module

    Thanks Ecniv...despite the advise of your Logo..I was panicing.... I reinstalled Office 2003 as well as the Service Packs (up to SP3) and now it works great! I don't know what caused it but it's all set now...Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width