[RESOLVED] HTTP/1.1 503 Service Unavailable-VBForums
Results 1 to 3 of 3

Thread: [RESOLVED] HTTP/1.1 503 Service Unavailable

  1. #1

    Thread Starter
    Addicted Member Rockhopper's Avatar
    Join Date
    Aug 2003
    Location
    Cape Town, South Africa
    Posts
    199

    Resolved [RESOLVED] HTTP/1.1 503 Service Unavailable

    Hi everyone,

    I was wondering if anyone had come accross this error.

    I installed Visual Studio 2003 on Windows x64 (with IIS 6.0) a few days ago, and i got an error that i'm hoping someone here knows something about.

    When i try open a web application, i get the following error:

    "The web server reported the following error when attempting to create or open the Web project located at the following URL: 'http://localhost/ApplicationName.' 'HTTP/1.1 503 Service Unavailable'."

    I found a fix somewhere on the internet last week that sorted out the problem... but i was dum enough not to save the link to the page and now i can't find the solution again. Today, i ran my web application again, and all of a sudden, i get the same error!

    I have been googling the error all day, to no avail. Everyone seems to have solutions that don't work. I have used ASPNET_REGIIS -i but that just starts the ASP.Net server, registers the web extension, and nothing much else.

    I can ping my localhost, but when i type http://localhost/ into a web browser it returns "Service Unavailable"


    Any ideas, please please please help... this has gone way past annoying.
    If the facts don't fit the theory, change the facts. --Albert Einstein

  2. #2

    Thread Starter
    Addicted Member Rockhopper's Avatar
    Join Date
    Aug 2003
    Location
    Cape Town, South Africa
    Posts
    199

    Re: HTTP/1.1 503 Service Unavailable

    Ok, after about 6 hrs (yes yes, i know), I found the Solution.

    Apparently there are about 1 billion ways (or there about) to cause an "HTTP/1.1 503 Service Unavailable" error. This is how i managed to overcome this...

    I am using Windows XP Pro x64 with IIS 6.0 in this solution.

    Step 1: View the computer event logs to find out the exact error (believe it or not, the error the screen shows is not necessarily the total sum of information on the error (Shock Horror)

    To do this... right click "My computer" and select "Manage". (alternatively type "compmgmt.msc \s" into Start>Run)

    Once there, select "Event Viewer" under "System Tools".

    You will find all the error information here. Double Click on the "error" line items. If you recently got the "Service Unavailable" error, try the most recent errors (u wouldn't have guessed that eh).

    If you're like me and installed Visual Studio 2003 onto Windows XP Pro x64 then you will most likely have these 2 errors:


    The first one:

    "ISAPI Filter 'c:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_filter.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a AMD64 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

    (Of course these links did not yield any information for me (Thanks MS) )

    The second one:

    "Could not load all ISAPI filters for site/service. Therefore startup aborted.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

    This one seems to be because of the first error... likewise the link never helped me.



    Step 2:

    If you still have the same error I had then try this...

    http://support.microsoft.com/default...b;en-us;894435

    The link title is "How to switch between the 32-bit versions of ASP.NET 1.1 and the 64-bit version of ASP.NET 2.0 on a 64-bit version of Windows"

    Try the bit under the heading "ASP.NET 1.1, 32-bit version"

    Just in case this link goes down like the others i have tried... here is the copy paste of the solution.


    ASP.NET 1.1, 32-bit version
    To run the 32-bit version of ASP.NET 1.1, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command to enable the 32-bit mode:
    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1
    3. Type the following command to install the version of ASP.NET 1.1 and to install the script maps at the IIS root and under:
    %SYSTEMROOT%\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i
    4. Make sure that the status of ASP.NET version 1.1.4322 is set to Allowed in the Web service extension list in Internet Information Services Manager.

    For beginners.. %SYSTEMROOT% is the Windows directory... in my case C:WINDOWS

    Now this initially did nothing for me... so i navigated to the link in windows explorer, found adsutil.vbs and double clicked. It then asked me if i wanted to enable cscript (or something like that - can't remember cos i clicked too fast). Once i double clicked a second time all went well.

    My Visual Studio was working again
    If the facts don't fit the theory, change the facts. --Albert Einstein

  3. #3
    New Member
    Join Date
    May 2006
    Posts
    1

    Re: [RESOLVED] HTTP/1.1 503 Service Unavailable

    Go To administrative Tools >>> Computer Management>>> Local Users And Groups >>> Groups
    Find Iis_wpg Group And Open It
    Add Yourself In That Group
    Go To "run" Type In "iisreset" And Enter
    Let The Iis Get Reseted And Then Get Going Without Any Problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Featured


Click Here to Expand Forum to Full Width

Survey posted by VBForums.